Wyze Plug won't factory reset

I have a few Wyze plugs and haven’t had any issues until I switched out the router. I went through the process of joining each one up and I have one that refuses to factory reset. I plug it in and the blue light blinks slowly because it can’t find the old wifi network. I hold down the button on the side for a long time (30+ seconds) and it never clicks and starts doing the fast blinking. (i.e. the factory reset) I tried googling but apparently no one else has had this issue. I left it unplugged a while and tried it again with no luck. Does anyone happen to know any options to try?

I tried to plug it in while holding the button down to see if that would do anything.

I haven’t had that issue, and as far as I know the button is the only way to interact with the plug if it’s offline. If you haven’t already you should submit a ticket to Wyze Support to make sure they’re aware of the issue. There may be a secret button combo, or it may need to be RMA’d.

Yeah, it’s 8/2019 so the year is past for the warranty. I might pop it open then and see if I can find anything stopping it from resetting. First one to die on me, and was working great until the wifi changed.

Any update on the fix? Mine just did the same thing. The exact thing happened, I changed my modem/router to a new provider and now the plug is dead. Just blinks blue, the switch is non-operational. I think I bought mine 10/2019

1 Like

Any update on this issue? I bought the 2-pack of these plugs in January 2021 and have had nothing but problems with them dropping off the network. I just went to factory reset them and holding the on/off button for a very long time does nothing. How is it that both plugs have seemingly failed at exactly the same time?

No update at all. The one I have still doesn’t work. No way to reset it that I can find. I never did mange to pry the case open because I didn’t want to dremel it open. It’s just sitting on a shelf collecting dust now. I guess it’s a “feature”. Just make sure you never retire a wifi SSID that’s connected to a wyse plug.

I have that problem too. Contacted customer service via phone and was told to reset by the method they have on file on the web site. That doesn’t work as Wraith7n has documented. I have 2 plugs that won’t reset. Whatever routine was originally memorized still exists and there appears to be no way to erase that, meaning the plug switches on at a programmed time I made last year for Christmas. After the holidays, I unplugged the plug and put it away. I have no idea of the time it was programmed to switch on and off and I can’t delete that routine in order to add a new routine.

I had similar issues after changing my router, and my 4 cameras and 4 wall plugs became total junks sitting in a box for months. I launched many reports— they responded to one, promised to follow up but didn’t — all while my cam-plus premium subscription was in force. Then I tried something that works for my cameras but not the plugs. I plugged my old router (with all the wireless network settings still intact) into the WAN port of the new router as an extension. I ran the setup for each camera and managed to revived them using the old network settings (network name and password). Unfortunately this doesn’t work for all my plugs except one. The exception was the one plug which I believe I did not try to run the setup for the new router so the settings in the plug just work after I connected the old router.

Now I have 3 plugs that don’t work and I’m not sure if Wyze would care to resolve the issues, judging from all your stories so far in this thread. I’m beginning to look at other home device brands.

I eventually took the wyze plug apart to try to find any way to clear the settings. Unfortunately, there’s no jumper or anything I could find to reset it once you have it apart. Getting it to come apart damages the case anyhow though, as it’s glued/sealed together. My guess is that they don’t really want you taking it apart. I ended up throwing the plug away. I’m not sure if there’s a way to prep them before you make any network changes to get them to forget all network settings so you can enroll them into a new network. I also can’t log into the wyse form anymore because the “I’m not a robot” kaptcha thing gives me this error:

Error: It looks like your adblocker is blocking our kaptcha service. In order to log in, please temporarily disable your adblocker and refresh so kaptcha can work properly. We need to make sure that you aren’t a robot!

I’ve never had this error from any other kaptcha services, and I assure you that I’m not a robot. Althought that’s probably what a robot would say. Oh well. Just word to the wyze, don’t change networks with your wyze plugs, as they might die forever.

I’m having the same issue. I have a wyze plug that disappeared from the device list, but still had the on/off settings that I had originally given it. I needed to use the plug somewhere else, but the setup process to add as a new device always fails in that once I get to the section to connect to the wyze “wifi” for the device then go back to the setup screen, the wheel spins for a few seconds, then nothing happens, so the setup process never goes past the “connect your phone to…” page. I’ve tried resetting to factory settings, but that process never works either. I’ve tried updating the app (it was already current), turning off cell data, forgetting the wyze wifi and starting again, unplugging the wyze plug and letting it sit for a while, I’ve even rebooted my phone (iPhone with IOS 15.1) Nothing works.

I finally got mine to work again. I had a feeling it was the iOS update.

I verified everything in these articles:

I then noticed that my Location Services for Wyze had Precise Location turned off so I enabled it and it WORKED. :grin:

I finally figured out my issue. The problem is that I am an idiot. Mine are Wemo’s, not Wyze plugs.

We changed out our routers at a few sites,but all the router information was manually put into the new routers,and all was good, we its the wyze plugs unplug the plugs with the blinking light and plug it back in and it should sink in

I’m late to the party, but I had given up on this issue for a year. I finally got them to work by turning on PRECISE LOCATION in the privacy settings for the Wyze App. Hope it helps.

I got one of my plugs working by turning on “nearby devices” permission for the WyzeBeta app on my Pixel5 android