Wyze Plug Stopped Connecting

Anyone else having issues with the plugs? Second day in a row, it sits there with the blue light blinking rapidly. App shows it offline. I can manually turn it on or off, but it refuses to connect and schedules aren’t running.

It has been working fine, I updated the firmware maybe a week ago. But unplugging and plugging it back in doesn’t resolve.

I had this issue in the past. I got it connected by going through the setup process. Interesting enough, the fast blinking is like it needs to be paired again. you can pair it without deleting from your app. Name it the same and all should be ok.

you may need to factory reset the plug first:


That’s what it took. Had to reset it, and then pair it up again. Very odd.

1 Like

Glad it worked out for you.

I am having similar problems… I have 6 Wyze Plugs - and after setting them up after a few days - 2 of them went OFFLINE. I reset one of them and reconnected it and it works OK now, but today (one day later) I again have 2 plugs showing as OFFLINE - the same one from yesterday that was offline that did not get reset is still offline, and a new plug is now showing as OFFLINE. I reset my modem to make sure it was not a connection issue. Is this a firmware update? I cannot continue to reset these plugs every few days.

Does anyone have a more permanent solution?


1 Like

There are multiple posts about this. Seems to be the newer bluetooth version and is most likely a firmware problem.

1 Like

I have this issue as well and am using Firmware v.2.0.179, which the change logs claim fixed a major connectivity bug in the .176 version. NOPE!

Does anyone know how to get answers from WYZE technical support? I have submitted a few diagnostic logs and tried the support stuff, I have used the “Route This Helps” app, but it didn’t help. I still have issues and I am losing patience.