Wyze Plug Firmware Update

My 4 plugs arrived and I finished setting up 3 of the 4. The 4th plug will not updated to the newest firmware. The first 3 have been updated to v1.2.0.206. It says it’s firmware is v1.2.0.53. So every time I open up in the app it says Firmware Update Required. Even when it’s unplugged. This is annoying. I’ve tried updating the plug 5 times already and it says to try updating again.

1 Like

I have the same problem. Ordered 2 new ones, one installed and updated just fine, the other fails the update. Not useable until updated

Does it say the update failed, or does it just not update

Yes. Update failed.

Hello! Sorry you are having to go through this. We have noticed this issue as well and are trying to get it fixed. Can you confirm if you are able to close the firmware update pop-up and continue using the plug without updating firmware? If so, could you please submit a log from the device plug-in page when it is online? A screenshot of the firmware update pop-up would be helpful too.

5 Likes

I just got 6 new plugs, and had issues updating the firmware on all, but finally managed to get them to update after many tries.

The update was mandatory on all plugs, so when you try to go to the plug from the Wyze app main screen, you are stuck, and forced to update, without the choice to cancel and you cannot even return to the app main screen. You are literally locked out of doing anything except to try to update the firmware.

But here is the trick I used to get the plugs updated… The secret is to make sure that the plug is in the OFF state, before applying the update.

Go through the setup process. I don’t remember for sure, but I think that at the end of the setup, it goes right into the mandatory firmware update popup.

At this point, the blue light was on solid on most of the plugs - I may have waited 30 seconds after the setup before the light was on solid blue. Push the side button on the plugs, to turn it to the OFF state.

Now let the firmware update run. This worked for all but one or two.

I think that if it fails, that i could again try to put it in the OFF state before retrying the update.

For those that did not work like this, I force terminated the app, then restarted it, and it came to the app main screen where the devices are all listed. it showed the plug in the ON state, and tapping the ON button, turned it to the OFF state even though the blue light was still flashing - at least I think I remember it switching to OFF. Then go into the plug properties in the app, and the mandatory firmware update puts you back into the point where you have to do it. If the plug is in the OFF state, the firmware updated worked for me.

There was one point where I had to delete a plug device from my account. You need to do this from the app main screen because you can’t get into the plug page to delete it. Then hold down the button on the side of the plug till it starts flashing, and re-add the plug to your account, and try these steps over again.

In one case, I unplugged the plug from the power, and waited a minute or so, then while still unplugged I went to the plug device page in the app. The app let me go to the page without forcing the firmware update, because the plug was now offline. Then you can delete the plug from there. Maybe you can also send the device log while it is in the off-line mode.

It took me about 45 minutes on this one plug trying various things like this to finally get it to work.

But I think the key secret, is for the plug to be in the OFF state when applying the firmware update.

Got it! Glad you were able to update all your plugs. Thank you for the workaround, I will pass it along to the users with this issue and we will fix these issues so that the update process works as expected. Thank you!

2 Likes

This “secret”, also applies to the Wyze bulbs (at lest the white bulbs). I got my first bulbs in March or so, and when I set them up, there was a firmware update available right out of the box. The update kept failing on those bulbs, but I saw a post someplace, that suggested making sure the bulb was in the OFF state to do the update. I turned them to the OFF state, and the update worked perfectly.

Unlike the plugs, there was no problem turning the bulbs off from the app home screen, and I did not need to delete the bulb from my account and try again - they updated with no problem if the bulb was in the OFF state, but failed in the ON state. I don’t remember if this affected the color bulbs as well, or just the white bulbs. I got and setup some of each at the same time.

I just got more white bulbs, and I don’t know if the same problem exists now as well, but took no chances and made sure they were OFF before trying the update, and they all updated without a problem.

You might ask them to check the bulb update process for this same issue as well.

Hello. I tried today for hours to update the plug firmware; different scenarios, including turning the plug to the OFF state, clearing app cache, removing and reinstalling the device, but the updates continued to fail. It’s so nice that the forum members are so helpful but really Wyze needs to find a solid solution to the firmware update failures. Thank you!

I think you guys probably know this now, but you cannot access the settings menu when the switch won’t update. So these devices are completely bricked until they can be updated, and we cannot share any logs.

In some cases (in the cases of these plugs), the firmware update is mandatory, so you are stuck during the setup.

It is very frustrating. I have 10 plugs, and have had this mandatory firmware update problem on every one of them.

But what has worked for me in most (but not all) cases is that if you wait a few seconds, the light on the plug will stop flashing. When it does, use the physical button on the side of the plug to turn the plug to the OFF state. Then continue the firmware update, and it works about half of the time.

Or, force close the app, then restart the app and it will start on the home screen of the app. Then from there, tap the ON indicator (or push the physical button on the plug) to turn the plug to the OFF state, then go to the plug device, where the mandatory update is forced, and update from there. That works about half the time.

Or someone else has reported, that if you force close the app, then restart the app to the home screen, then go to “Account” (bottom right), then go to “Firmware Update”, then pick the plug to update, then he reported it works every time for him.

I found a real simple solution that didn’t take any time and saved me HOURS: I SENT THEM BACK TO AMAZON.

I today’s market selling a marginally effective device is unacceptable. I have been working on seting up my plugs for four hours. At my normal billing rate I should have just gone with Logitech and saved myself the time.

This actually worked!!! Why doesn’t WYZE make this known?