New Wyze Plug won't upgrade firmware

Just bought a 2-pack of Wyze Plugs at the local Home Depot. Naturally both of them had out of date firmware and needed an upgrade. The first one upgraded with no problem and so far works fine. The second one refuses to do the firmware upgrade, and without it I can’t use scheduling which is the main reason I bought them.

Do I need to drive back over to Home Depot and return them?

I have four Kasa smart plugs on order from Amazon. Maybe they’ll work better. I was hoping to be able to stick with Wyze as I’m building up a bit of an inventory of Wyze stuff (bought another floodlight camera at the same time that I bought the plugs). If I can get the Wyze plugs to do what I want I’ll return the Kasa ones. But now, maybe not…

I have had some issues with Wyze plugs updating after purchasing them in the past.

Some steps to try (in any order):

Try unplugging the plug for a minute, then try again.

Try deleting it from the app and setting it back up.

Thanks, @IEatBeans. Yes, I had already tried that, several times. I also tried deleting the upgraded one from the app, and then reset the non-upgraded one to factory config and tried again, in case there is some kind of goofball conflict in trying to install a plug where another plug exists. Nothing works with this one.

I’ll give it until tomorrow AM in case there is something going on at the firmware server, then I guess it’s back to Home Depot I go…

Have you tried deleting the non upgrading one?

Yes, that’s the first thing I tried. Then I deleted both of them and added in the non-upgrading one first, still no joy.

Then, just now, I decided to try it one more time before giving up for the day. Deleted them both and added in the non-upgraded one first. It worked! The previously-upgraded one also works.

Gee, maybe standing on one foot and waving a dead chicken over it while reciting the Marine Corps anthem really does work! :slight_smile:


I’m glad you got it working! Not sure why it is finicky like that, but it only seems to do that the first time, later updates don’t have any problems.

I experienced the same thing. I had 2 of 4 giving me fits. Then out of sheer frustration I tried again for about the tenth time and voila they worked. I guess time will tell how they perform.