Wyze Plug 2021 firmware update fails

My Wyze plug 2021 is on firmware The Wyze app says a firmware update is available, and I have attempted to update it numerous times; however, the update fails repeatedly. The plug still works as normal and can be controlled via the app. I have power cycled it several times.

Welcome to the user-to-user forum, @Alex12345 ! :slight_smile: is the current Plug 2021 production firmware (released 4 days ago), and there is no further Beta yet to the best of my knowledge. Can you screen capture the screen that says what version it wants to update to beyond

Good news! My Wyze plug is on firmware 12.0.3. It continuously asks for Firmware update, indicates everything’s good , you’re upgraded. Still I cannot set a rule to work nor time of day with 1 of 2 plugs (i.e. plugs w/in unit). Answer from CS? IT is aware of this problem and working on an update to solve this.

No, sorry. After I restarted my phone I no longer get the update failed message, nor the update required msg. Thanks for the info.

1 Like

You should still be able to schedule your plugs. Just create a scheduled rule with a start and stop time. :slight_smile:

Hi, I just got my 2 Wyze plugs and they are on firmware but every time I want to upgrade to the update fail. Same thing on both plugs. Anyone knows what is the problem?

What device are you using? Android or iOS?

I would do the following:

  1. On both, Android and iOS, go to Account then App Settings within the App. Then Clear Cache. Note: This will remove the Thumbnails of your camera’s until you start your live stream again. NOTE: On Android, you can also long press the app and the do a force stop.

  2. Restart your Device - Safety to make sure there is no Cache or App issues hanging around.

  3. Remove the Plug from the wall for about 10 seconds and then plug it back in and let it connect to your WiFi again.

  4. Try the Update again.

I have found that resetting the power on the device you are trying to update seems to allow the updates to occur. the other steps are what I have done to assist in this as well.

1 Like

Hi @spamoni4,

Thank you for your help. I’m using the Android app (I tried with my phone and tablet). I never had issues upgrading other devices/cams. I followed your procedure of clearing the app cache and restarting the device but again it did not work.

The wifi connection is stable anyway. I just miss having the option for Time of Day local scheduling. Until a fix is available, the scheduled rule with a start and stop time seems to work. But it is not the real deal.

1 Like

Sorry it did not work for you.

You could create a Log and reach out to Wyze.

1 Like

If you are using DoT to encrypt your DNS calls, temporarily disable it then try the update.

FYI I am having the exact same issue and tried the suggested fixes and still failing. This is a first for failed updates for me they usually go smooth but this version from does not like the update for some reason.

1 Like

Also note I have had this update failure on (2) Wyze 2021 plugs brand new right out of the box.


I saw there is a new firmware available But again, trying to update from always fail. How can I hope to get new functionality or bug fix if I’m not able to have a firmware update in the first place. This is the chicken or egg paradox.

I just confirmed that I was able to update my plug to the newest firmware. Do you have the Wyze Plug 2021 or the older version?

1 Like

Hi @rhousen thank you for replying that pushed me to try again and it finaly worked but not in a flawless way. Yes I have a 2021 version with a key symbol printed in the back of the plug.

What I did:
1- I started the firmware update only to be told again by the app that it did not work and if I want to try again.
2- I deleted the device from the Wyze app.
3- Unplugged the plug from the outlet and replugged it.
3- I restarted the setup steps as if it was a new device.
And that’s it! The new firmware version was finally there. So, not a very elegant process, but at least I have access to the “Time of day” function.

These things are garbage and there’s nothing in the faq and error messages are useless. Three hours trying to get a plug to work. Wyze app “isn’t supported” on my pixel slate. Try to install the update on my pixel 6 pro, and it fails without any clue as to what the problem is, only solution the app offers it to “try again”. I can see the plug on my router with a 2.4ghz connection and a good signal. Remove the device from the wyze app, power cycle it, try to readd. App pretends it doesn’t exist and it’s “probably because it’s not close enough to my phone” OK app, that’s not the problem, thanks for reminding me how much you suck at this. Reset the plug by holding the button for 5 seconds and try again, it’ll connect but fail the update again. Also can’t turn it on or off from the app.

Has anyone from Wyze heard of error messages? Loading bars? Has anyone considered that whether something is failing at 0% or 30% is useful information?

1 Like

Just tried resetting both plugs and using a different phone, same result. I would try to guess the plugs can’t communicate with the internet, but it would only be a guess, since there’s zero ability to actually test such a thing. Lovely devices.

I’m glad it finally worked.

Try disabling data over mobile and if you are using DoT to encrypt your DNS calls, temporarily disable it then try the update. I had the same issue until I disabled DoT on my router.

I am having the exact same problem. Plug is new. It was initially recognized and installed. It then said there was a firmware update to 126 from 53. Multiple tries failed.