Wyze Plug Outdoor Firmware Released! - 8/30/21

Happy Monday, Forum Friends!

Wyze Plug Outdoor firmware is releasing today! This adds a pop-up if WiFi signal strength is low as well as a status message during firmware updates. :zap:

Read our Release Notes:


Update completed without a hitch.

I’ve had my WPO running for about a week now. Hopefully it continues running smoothly with the scheduler after this update… :upside_down_face:

1 Like

My two attempts to install and immediately update firmware, were a disaster.
Both units are being sent. Very frustrating.

Sorry dawwg… Been in that boat plenty myself.

Hopefully your WPO wasn’t bricked and still works on the previous firmware.

The units would not connect after multiples attempts and guided support from WYZE.
Sent them back…

Ouch… Definitely a worst-case scenario :roll_eyes:

I setup a schedule (local) for the Plug Outdoor: On at sunset and Off at 11pm. Works as expected.
BUT When I turn that schedule off with the App, it STILL keeps running the schedule.

It does not update the Plug when I turn the schedule off or change the days off.
WiFi signal is 2 bars, everything works as expected (manual on/off). I also tried unplugging the plug outdoor and forcing a re-boot.

It seems the local schedule can’t be changed anymore…

Anybody find this problem too?

I’ve just unboxed my first outdoor plug Tested inside first. When I try to set the “Time of Day” schedule I get a popup that the firmware ( needed to be updated. I press the “Update” button and it says “Everything’s good…” but still at I need the time of day feature because the location I need to use this plug has little of no wifi signal. How do I get the update?



Wife wanted our Christmas tree on a timer. Remembered I bought two Wyze Outdoor Plugs and only used one. The plug joined the Wyze app fine. Exact same thing happened to me when I tried to make a schedule. App wanted to update the firmware but says it is the latest version. My other outdoor plug is at so there IS newer firmware.

This is the message I receive when I try to create a schedule :

This is the message I receive when I try to update the firmware :

I have disconnected the outdoor plug from power with no change.


Same issue I have except my current firmware level is Outlet is worthless to me without that function.

1 Like

It is updating now.

What did you do to make it start updating? Mine is doing the same thing saying to update but then saying it’s good without making any updates. It is stuck on update 1.2.086 which I can’t even find as a firmware update. So frustrating

I left it plugged in. The planets might have been aligned also.

In other words, I did nothing.

1 Like

Well I guess we will see if the planets align again :slightly_smiling_face:

1 Like

I am on day 3 of having mine plugged in and still no update and pretty much as expected no reply from Wyze. Support will be their downfall.

1 Like

Part of the clue might be that your outdoor plug shipped with a different firmware version than mine. Hope your issue gets resolved. My experience has shown a call to Wyze support is better than an email or bot chat.


Thanks. I have 6 Wyze cams, doorbell, vacuum, scale, door lock, bulbs and sensors. The manufacturing part is first class. The software is often shaky and my experience with their support is dismal.

I literally just got this plug. Plan was to control outdoor lighting for a pergola. I’ve never gotten it out of my house since the update issue was out of the box and I was doing the initial install from inside. The Time of Day feature is supposed to work on a schedule I can set that will work even if the plug has no wifi signal when put in place.

It is sad to me that Wyze has such potential but now has a reputation all over the internet for not providing customer support.

Thanks for your email and update.


Hi , I just got mine and installed yesterday with same issue as you with firmware say up to date but its not the latest firmware Wyze released. I need to get the local schedule tab activated. I will try to factory reset again.

Same here! Shows firmware out of box and claims up to date but Time of Day function says update to use. Anyone find a manual way to update these? Anyone talk to support for a fix? I am going to open a ticket and try to get an answer.