Wyze Video Doorbell Pro, Wyze Plug 2021, Wyze Switch, Wyze Plug Outdoor Firmware Beta Test 1/3/2022

Wyze Video Doorbell Pro:

Firmware Version:

  • 1.0.58

What’s New:

  • Added more tones

  • Improved Event triggers

  • Fixed a battery indicator bug

Wyze Plug 2021:

Firmware Version:


What’s New:

  • Added Bluetooth firmware logs if the plug has trouble with setup.

Wyze Switch:

Firmware Version:

  • 1.2.21

What’s New:

  • Improved connectivity performance so that Wyze Switch reconnects faster if signal drops

  • Feedback is sent to our team if the switch loses connection and gets stuck so our team can investigate which part of the connectivity failed

  • Improved Schedules

Wyze Plug Outdoor:

Firmware Version:


What’s New:

  • Added an optional automatic update feature

Installed the update to my switch, plugs and outdoor plugs without issues. Will now commence testing.

Looking good so far.


Just ran a bunch of tests, schedules, and Rules. Everything functioned as expected.


Updated my outdoor plug, no issues at all from what I can tell.

1 Like

Since this update, my four Wyze Plug 2021 lost wifi connectivity and show the cloud icon where the on/off button used to be. I have tried unplugging them and plugging back in with no luck. Local “time of day” schedules continue to work as programmed.

SOme of us have experienced weird issues like this with the plug. Easiest thing to do is to try one of the following:

  1. Press the power button on the side of the plug until the light starts flashing relatively quickly, I think it is about 20 seconds or so. The go through the new device setup for the plug. This corrected mine.

  2. Remove the plug and then do a new device setup.


@WyzeAndy @WyzeBaohua

This is the second time this has happened with Firmware version

Android App 2.28.0 (b99)

One of my 2021 Plugs has lost connection fully, almost as if it was factory reset. The Blue Light was blinking fast and the app showed the plug with the cloud and a line through it. All I do is, start the app and go to add new device, pick the plug and it sees it as a new plug an goes through the setup. At the end it is functional. The plug has nothing plugged into it and I have stayed away from it to make sure I didn’t push the power button by mistake. So something is going on with it.

I submitted log 438567 from the plug itself. It was done after adding it back to the app, hopefully that will not cause an issue.

I know others have seen this as well, so wanted to make sure you all were aware. Hopefully the log will be sufficient.


My 3 Wyze switches fail everytime I try to update the firmware. I have re- setup and power cycled many times and can’t get it to update. Any fix?

Welcome to the community @nwgeorge98

Can you provide the FW you are currently at on the Switches and include the App Version you are currently running as well.

Sorry to hear you are having issues with doing a Firmware Update. Here is what I would try, and I know it defies logic. However, it has helped with other FW updates on other devices.

  • Start the Wyze App
  • Go to the Account Tab
  • Tap on App Settings
  • Tap on Clear Cache
  • Log Out of the App, at the bottom of the Account Page
  • Reboot the Device - Looks like you are using an Apple Device

Then log back into the App and see if you can do the update from the Firmware Update Section or from the Device Settings area of the Switch.

I am also tagging @R.Good as he has had some issue with his switches and may be able to provide additional insight.

1 Like

Thank you I will try that. Also I am running app version 2.28. The FW version of 2 switches currently are 1.2.20 and one is 1.2.16 and won’t get past this.


Tried clearing cache and resetting iPhone and it still won’t update. I am hoping this FW update fixes my connectivity issues but I can’t get it installed. I have many Wyze products and this is the only one ever having this issue.

So I held off… This now sounds like my issue.

Are your switches constantly disconnecting?

1 Like

I was thinking that as well. If I recall, you were able to get the FW installed bu doing a temporary work around, correct?

Yes, but the firmware update did not resolve the issue. The work around was to delete the switches. Connect them using my phone as a mobile hostspot, then update the FW… delete the device again and re-add to my LAN.

Still seeing the disconnect issue with .21 Firmware.

Curious @nwgeorge98, who is your internet provider and what model of Wireless access point do you have?

I have 2 separate Wireless Access Points and when I put some of my switches on my secondary WAP… they worked fine.

I am still digging and have one of my switches still on the unhappy network and have been providing updates to @WyzeBaohua

I will probably do that as well too. Xfinity is my internet provider. The model is CGM4331COM. For my router

Yes they are constantly disconnecting and I have to shut off breaker to get it back online

Interesting my IoT Wireless Access Point is a Spectrum Askey RAC2V1K (which looks similar to your model) my switches do not like it. I have gone through it with a fine tooth comb in terms of setup and Firmware and cannot get the switches to like it.

If I move the switches to my TP-Link AC5400 they operate perfectly.

Still troubleshooting, but running out of ideas.

All 100+ of my other Wyze devices (and many other IoT devices) operate without issue on the RAC2V1K, it’s only the Wye switches that disconnect every 90 seconds or so.


My Wyze Plug 2021 went offline again. I unplugged it from the outlet and plugged it back in which seemed to bring it back online. I did submit a log for this. Log # 452848.

Hope the log helps out.


@WyzeBaohua , I wanted to inform you that my Plug once again lost its setup and was blinking quickly as if it was not connected. All I did was perform the Add New Device, selected the plug to add, and it did indeed discover the plug which was flashing. Went through the setup and it is working fine again. Did not remove it from my app this time. :slight_smile:

This is a test plug so nothing is plugged into it and the power is normally off.

I submitted the following log after getting it back online as I could not submit a log when it was off-line:

Log # 468665


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.