Wyze Plug 2021 firmware update fails

Same issue as above. New plugs last week of January 2022, insist on updates and fail every time. Tried all the suggestions above. The update listed as available is 53, “time of day” says I have to update to use the feature.

I have the same problem. When I do get them to sync with phone i cannot schedule a fixed time. I gave up w/Christmas lights

To schedule the plugs you have 2 options. “Rules” or “Time of Day”. “Rules” require an active Internet connection to work. Time of Day will work even if you don’t have an active Internet connection. Also, you’ll need firmware 1.2.0.126 or newer for “Time of Day” to work.

Try this: Delete the plug from the Wyze App, then disable data over mobile (a fast way is to activate Airplane mode then turn on Bluetooth and Wi-Fi). Also, if you are using DoT to encrypt your DNS calls, temporarily disable it before trying the install. Next, install the plug and then update your firmware. Don’t forget to enable your phone’s data after you finish. Good Luck!

1 Like

Thank you. I followed what you said. The rules unfortunately do not work. Let’s see next time i need an outdoor plug…for now? Not worth the headache & calls to CS. Tired of the calls. I had a huge problem w/video Doorbell. After 10 emails & 6 calls got a replacement. Lol

Are you using an indoor Wyze Plug outside? Or a Wyze Plug Outdoor?

What is your current plug’s firmware version? 12.0.3 is not a valid version number.

What is your Wyze app version number? Wyze app Home > Account > About

1 Like

A quick tip for firmware updates when using the app. This applies to any device tied to a given account. While using the app, do not update the firmware from the device itself. Instead, when you open the application, go to Account, then select Firmware Update. I highly recommend installing all firmware updates using this method.

I have a brand new 2-pack of Wyze Plugs and the firmware update (“bulk update”, via the “Account” screen) is failing on both units.

The factory firmware is 1.2.0.53 and the new firmware is 1.20.126.

What can I do?

How long should the update take?

I had the exact same problem. Also two brand new plugs. Tried everything - rebooting plugs and phone multiple times, deleting devices and starting over, etc FINALLY, after a dozen or so attempts on one and even more on the other it worked.

So frustrating! Doesn’t Wyze QA these releases before launching them?

Many suggestions include “delete plug from Wyze app” but I can’t get that option. As soon as I touch the plug in the app, it prompts for update. Whether wait for it to fail, or cancel, it goes back to list of devices. How to get the gear icon for the individual plug to allow delete?

1 Like

On the screen of devices you can hit the pencil on top and delete the device from there by clicking the red - symbol. I at least that’s on my android. I just figured that out since I was having the same issue of not being able to update or delete the device.

This worked for me Thanks

This worked for me Thanks. Did all the same steps reset the device and it worked Finally

1 Like

Thanks for your Post. I was having the same issue and wasted 2 hours trying everything possible, Finally after deleting both Plugs by using the Pencil Icon and “Delete Device” and doing the setup again, they both worked from 53 to 203. I have multiple Wyze devices and had never had this problem before. Wyze, if you are listening, clean up your act on the Wyze Plugs to avoid future frustrations on all of us.

I’m having the same issues - bought a pack of 4 plugs - all 4 of them are doing this trying to upgrade from 1.2.0.53 to 1.2.0.206. Finally I got one of them to upgrade after several times deleting and re-setting up the plug - no luck on the other 3 - working with support in a chat session now - I have literally dozens of Wyze devices and have never had issues like this…

They walked me through a few things that didn’t work and then said I “may” be eligible for a replacement if i send them all the info on the device and the info on the purchase… nothing like wasting a couple hours trying to get a $10 POS working…

I sent Wyze the following after my problems with the plugs:

If setting up new 2021 plugs out of the box. DO NOT update the firmware when it asks you to do so, instead cancel the update. Then go to account | firmware and update the firmware from that page. It works every single time without a problem. Whereas updating when it prompts during the setup process is totally hit or miss. This has been the case since the 2021 plugs hit the street.

There is a reason WYZE has quietly created a new 2022 plug. Likely many reasons that they aren’t going to tell us about.

Ok, your mileage may vary on this, but I managed to get 2 of the 3 that were failing to set up finally the magic for me seems to be:

  1. unplug the device
  2. delete the device in the app (if you had already set it up once)
  3. Clear the app cache (Don’t know if this is really needed, but I got into the habit of doing it on every attempt)
  4. Force close the app (Again, don’t know if this is necessary, but I want to make sure there is NOTHING in memory related to the device)
  5. Plug the device in and press and hold the button for 8-10 seconds (should make it do a full reset)
  6. Go through normal setup
  7. When it tells you that it needs to update the firmware, DON’T say ok, until the light on the device stops blinking - it should be solid blue before you allow it to try

That has worked on 2 plugs now that had failed the setup process repeatedly

5 Likes

Thanks jkarnes!!! I had to brand new plugs out of the box and the firmware update failed on both of them. Your steps resolved the issue on both plugs. Much appreciated.
Side note: I have two cell phones running the Wyze app so during this process, I shut one phone off completely just to be on the safe side. Overkill - perhaps.