Wyze Plug Can't Set Time of Day

Just got a pair of Wyze plugs for Christmas lights. They paired easily and seem to be working (we’ll see if I set the rules up correctly). They both called for firmware upgrades to straight away and both came back online when done. Both show they’re on the new firmware under settings. The problem, though, is when I click on Time of Day under settings, the app tells me the devices need to update the firmware to use this feature. If I click upgrade now on the pop-up screen, the app tells me “Everything’s good, you’re up to date.”.
I wanted to be able to have schedules run in an area with no internet, and that’s what this feature says it does.
Any ideas about the firmware issue?


Nope,we have our plugs set up.to auto on/off all under the rules

Very nice that they are implementing this feature! Can’t wait to see how it works. A commonly requested feature. Looks like it is only for the new 2021 Plug at this point, though.

I suspect this is a case of the app getting ahead of the firmware. So far ahead that there doesn’t even seem to be any corresponding Beta firmware yet. So just sit back and wait awhile, and I’ll see if I can shake some tree branches. :slight_smile:

1 Like

Did not know this existed. Will be interestedin what you find. This is a great option.

1 Like

Just received 6 new plugs. All updated with latest fw. But time of Date didn’t work. Always asking for update.

Replaced three old plugs with the new ones where the 2.4Ghz wifi is repeated by a wifi extender. If the new plugs can remain online with the unrepeated wifi then I can turn off the wifi extender. Will see.

I’m having the exact same problem. I have an outdoor plug and it works as expected. The indoor plugs send you in a loop saying you need to update and when you do, it says you have the latest version but the Time of Day still doesn’t give any options except to update.

Interesting so what did customer service @ Wyze say?

I haven’t received a reply back yet.

The app was issued in advance of the firmware, so stay tuned.

1 Like

I’m having this same issue exactly as described. On my roommate’s iPhone it says “everything is up to date” but on my Android it says “oops! The update failed!”

The only reason I bought the Wyze plug this week instead of a basic Christmas tree timer was because I thought it could, at minimum, be scheduled like one but also have the benefit of voice control. Without being able to schedule the Wyze plug, I’m left with a half usable product for what I intended to use it for.

I never thought it would be an issue.

Have you signed out/in on the app?

I heard back from tech support within an hour of asking my question. It turns out the “Time of Day” feature will be uploaded to the plug in a week or two. In the meantime you can set up a rule to accomplish the same thing. The difference between a rule and “time of day” is if the internet goes down the “time of day” feature will still work where the rule requires the internet. My old Insteon system had a “time of day” feature and I could move a device to another location that didn’t have any internet and it would still work.

I would still buy the plug. I just ordered 8 more for all the christmas lights around the house.

Looks like the Beta software has caught up (remember this is Beta firmware for test, and as such should be expected to have bugs – you may want to wait for the Production firmware that follows later!) Also, even if the new feature does currently show up in the Production app, you should be running the Beta app to use any Beta firmware:

Wyze Plug 2021:



What’s New:

  • Added support for Time of Day local scheduling

Yes. Even went as far as uninstalling and reinstalling the app, Deleting the device. Signing in and out. Etc. I’ve ordered a different brand of smart plug that can actually be scheduled. May be returning the Wyze plug. The product page said it could be scheduled like a normal plug timer but it doesn’t seem to be the case at all. Very disappointed.

The rules panel says scheduling is for notifications. I don’t need notifications for my plug. I was able to set a shortcut for the Wyze watch but it’s not much different from tell Google Assistant to turn the plug on and off.

Same issue here - my ISP is spotty and would really appreciate this feature working.

Same issue here. I hope the firmware update that enables this feature also has sunset/sunrise choices. The Lenovo plugs I replaced with these had these features and I thought those were junk, thus replaced them with Wyze plugs.

The latest Beta FW corrected this. you can now set the time locally.

1 Like

I’m having this issue as well. It tells me to update to use this feature. When I click update it says I already have the latest update and still doesn’t work. Firmware

This feature works perfectly on the indoor plugs. I don’t understand how this is being sold advertising this ability and it doesn’t work.

Does Wyze respond on these post or just the community?