Wyze Plug & Alexa


I have added a new Wyze plug. Followed the Alexa integration directions on the Wyze site and constantly receive response, “Plug is not responding. Please check network connection and power supply.”
I can operate the plug from both the Wyze and Alexa app manually. I have deleted the plug from Alexa app and disabled the Wyze Skill and re-enabled it. It finds the plug but…will not work (simple On/Off) with a voice command.

I have run out of ideas. Any suggestions?

I would try asking the Echo device to “discover devices” and try the command again even if you get a “no devices found” message. I would also try power cycling the Echo device.

Hi. Well, I have tried those things. Alexa sees the plug and it is listed in Devices. I can operate it manually from within the Alexa app.

I have several Echo devices but the response is the same no matter which I try.

I have pulled the plug and replugged it into the outlet. It is found on the network and within Alexa app.

Just will not work with voice command.

I deleted the plug from both apps and started from scratch, again. Same result. This plug is being used to light up the Christmas tree and I had named it as such; Christmas Tree.

But, the result was the same; Per Alexa, the plug was not responding and I should check the network and power connections.

For testing purposes, I simply changed the name of the plug, to Xmas Tree. That did the trick. It seems Alexa will not recognize the word Christmas. Odd but also sad. Could this be by design I wonder? Has anyone encountered something like this with Alexa integration?

I am having the same issue with all of my Wyze Plugs I bought. I have tried every suggestion I have run to on here and other places they still will not allow Alexa to control them. Very frustrating. An answer to this issue would be wonderful because we would like to use these plugs as advertised.

This is definitely an odd issue because I have a Wyze plug setup with Alexa and it is named “Christmas tree” I haven’t had any issues with it. Could you try changing the name back? Changing the name may have just been the solution to the issue.

I can try that again I reset everything and tried it again but it did not work after discovery. All of the manul options work just not the plug. The Light I bought from you does the same thing only works manually. When I say manual I mean with Wyze app or physically turning it off. The routines work fine as well just not with Alexa. I have 3 plug and none of them work.

Have you tried to disable and re-enable the Wyze Skill in the Alexa app? My Wyze plugs work great with Alexa voice commands and routines flawlessly.

1 Like

Welcome to the Wyze community @1stchoicesatellite!
Definitely they the renaming trick. If that doesn’t work try un-linking and re-linking the Wyze skill as @StopICU33 said.

1 Like

Have done those but can try again. I found that trick in a support forum but it did not work. Like I said I even deleted from Alexa and took plugs out of the app then started over new. Alexa discovers once pairs and say it is ready to use. I ask Alexa to turn off the name of the plug or the default name and it says sorry something is wrong to try disabling and reenabling in your Alexa app which I have done multiple times. In the Alexa app, it says the server is unresponsive under Wyze Plug

1 Like

That’s really weird. I hate to keep suggesting things you have already tried. I know that’s frustrating.

Do you have any other Wyze products working with Alexa at all?

And one last thing to check, in the Wyze app under Account > Works With does it show “Alexa linked”?

I would definitely reach out to Wyze support and see if they can help resolve this issue.

Contact Wyze Customer Support (206) 339-9646 Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT or make an online request here .

1 Like

Cameras work V2. Light bulb and 3 plugs do not. My shows linked Alexa. I submitted tickets twice along with pictures and products a few weeks ago but they never reached back out to me. Submitted it through the app. I really do appreciate your help it’s been more than I’ve gotten from wize.

1 Like

I won’t be much help but when I discovered a name change worked, I ran with it. Figured, this time anyway, it was an Alexa issue. Still working, -Christmas.

Maybe contact Amazon support about this.

ALEXA FIX!!! Same problem. It all worked until about a week before Christmas and then no Wyze devices were recognized by Alexa. I happen to stumble upon something here in the forum that fixed it all. Delete all Wyze devices from Alexa then go into the Wyze app and rename each device… you don’t really have to rename it, just add a space or something and then put it back the way it was and hit SAVE. Do this for every device. IT ACTUALLY WORKS with no help from Wyze or Amazon!!! Then make sure Alexa is linked into Wyze.

1 Like

Same problem. I fixed it and posted how. Search for “ALEXA FIX!!!”

[Mod Edit] A duplicate post has been deleted.