Alexa not recognizing Wyze plugs

I’ve tried unsuccessfully to integrate my Wyze plugs with Alexa. From the Alexa app, it will not find the plugs even though I was able to add them to my Wyze app with no issues. They function as they should from the Wyze app but what can I do to get them to work with Alexa?


Have you added the Wyze skill to Alexa? It should look similar to this? Be sure to let Alexa discover the plugs.

Yes, I have downloaded the skill. Will not locate the plugs.

Ok, more than download, you must also sign into it with your Wyze ID and password to connect the skill to Alexa and Wyze. Or you can go to the Works With section of the Wyze app on the Account tab.

After I received and added my plugs to the network, I had to disable the Wyze Skill for Alexa and re-enable it before my plugs were actually usable.


Sorry, I should have been more clear. I have also signed into the app as well and the skill shows linked.

Hmmm, well I admit to being stumped. Linking was painless for me and worked first time. I think your next step would be opening a

> support ticket.

1 Like

I’ll give that a try

Disabling and reenabling the skill worked. Thanks for the tip.

1 Like

Thank you, Wayne Luke! After hours of frustration, disabling and then re-enabling the Wyze skill finally allowed Alexa to recognize the plug.


Ran into another issue last night trying to add another plug. The process would not go beyond step 4. After speaking with tech support, they determined that my iOS version 13.1.3 was the issue. Upgraded to 13.2.3 and was able to add the plug successfully.

1 Like