WYZE Laboratory Site is Up :)

Tried on multiple browsers, platforms, cleared cache and cookies… all no go’s to get in.



This is Centercode, a site used for hardware testing.
I’m not having any issues with this. What browser are you using?
@R.Good this may have been a short term issue, is it solved now?


I’m not having any issues either, so this is weird if you’re having issues on multiple browsers and platforms.

Did you try switching from WiFi to using Cellular data? Or reboot your router, or check that you aren’t running a VPN.?

Was all on my home PC, then mobile… all down for about 30 minutes before I posted, just tried again. I am able to login and apply.



Yeah, must’ve been a temp issue of some kind and was working by the time I checked a few minutes later. Whatever it was, at least it’s working.

1 Like

I like that they are sending out “not selected” emails now. I feel better about unregistering from the project vs. still wondering if there is an opportunity.

I agree. I am not confident I’ll ever get picked, since so many other great testers they use all the time are already in my state, but I’ll keep applying anyway. Maybe one day I’ll for a demographic the other go-to guys don’t fit.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.