Wyze integration not working in Google Home

I’ve had Wyze integrated into my Google Home account for not than two years without issue. Recently about a week ago I noticed all my Wyze devices showing offline in the Google Home app. I tried reconnecting Wyze but I got an error. I then removed Wyze from Google Home and that was fine but when i tried to connect Wyze Home again I enter my email and password but then when I click sign-in i get an error.

Something was wrong.Please try again.

I’ve tried force closing, clearing cache, and clearing data for the Google Home app. Also did the same with the Wyze app. Restarted my phone and tried linking Wyze Home in the Google Home app on a different device as well but still get the same error.

I called Wyze support today and they said there is a known issue and it’s being worked on by the engineers but that it’s been a known issue since early May. If true, I don’t expect a fix anytime soon. Anyone else have this issue or way to fix this? This is really frustrating and making me lose faith in Wyze unfortunately.

Running Google Home on Android 11.

Wyze Home still linked, plugs, thermostat and cams loading. Just caught this critter prowling out back. Shot from the cam live feed in Google Home:


I’m running Google Home as well but Android 12 on a Note 20 Ultra. But I still have the same issue when I tried on my wife’s phone which is a Note 10+ running Android 11.

I wish I knew what the issue was and could get it linked again.

:man_shrugging: Cant even begin to speculate. Google Home is really not my go to app. It has been very unreliable and lacks the feature integration and compatibility that Alexa has.


That’s the thing, I’ve been using it for years with no issues. Now that i think of it, it’s been since late 2017 I’ve been using Google home. I’ve no issues with Wyze integration when I started using it with the plugs and V1 bulbs back on 2019.

I recently started playing around with a raspberry pi 4 I had lying around with Home Assistant about a month ago. Unfortunately Wyze isn’t supported (they use to be but have since locked down their eco system) so this might be the push I need to run everything in-house on my own smart home server.

It’s unfortunate as I’ve always enjoyed Wyze devices for the most part (not going to talk about their horrible thermostat) but I’ve been happy with their cameras, plugs, bulbs, sensors, vacuums, air purifier, scale, headphones, etc…you get the idea :grin:

1 Like

@Frederik do you have any idea what is going on? I even tried changing my wyze account password and still get the same error when trying to add Wyze Home in my Google Home app.

Please help! I have tried everything I can think of and still no luck! My wife is getting frustrated because she can’t pull up the babies broom on my Google Home screen or turn on/off bedroom lights and the fan with her voice right now.

does it just show the live feed or do you have to use the mic to get it to show in the app?

Same as before. Voice commands only.

Ah of course, hope they fix that

I’ve been having this problem too and I really hope they fix it because the lack of voice control is awful.

I was able to fix it by changing my two-factor authentication from authenticator app to text authentication. I also ended up changing my password too in the process so if it doesn’t work for you by just switching the two-factor method I would try a combination of changing/disabling two-factor authentication and changing your password.

I hope that fixes it for your too!

I am assuming once it’s linked back to Google Home, You should be able to switch the settings back to whatever you want.


I don’t have 2 factor authentication on and have changed both my Google and Wyze passwords as well. I guess I’ll try turning on 2 factor and then off to see if that works.

Thank for the hint @auhnivek,

I was also having the error “Something was wrong. Please try again.” When linking my Wyze account to Google Home.

I added Text based two factor authentication to my Wyze account and was immediately able to link it to Google. I did not have to change my password.

1 Like

Yes, thank you @auhnivek for this tip! So strange and weird that all I had to do was turn on 2FA in the Wyze app and i was then able to link it in Google Home again.

That said, I’m thinking Google and/or Wyze updated something to require it for additional security or something in the last few months. And if you already had it linked, it was fine but if you wanted to link (or relink) it would give this error.

I feel like we won’t be the last ones to have this issue but at least we know a solution.

1 Like