Google Home fails to connect to wyze after wyze account password change

hi, i recently updated my wyze account password and all my wyze devices are no longer connecting to wyze home anymore.
here is all that i have tried:
#1 - tried to re-add wyze service thru ‘works with google’ link in google home, but it ends up getting error message with ‘no compatible device found’
#2 - tried to reset wyze cam v2 and readded wyze camera in wyze app and then tried readding wyze service in google home, same error message as #1
#3 - since all the wyze devices shows offline, thru one of the offline light i was able to get to settings section in google home and tried to click on ‘unlink wyze home’ but did nothing instead it took to same page when ‘works with google’ link is clicked
#4 - i have 2step verification setup and somewhere i read to use 2FA text message, tried that instead of authenticator app, same issue
#5 - i turned off 2step verification and tried to reconnect and got same issue

Does anyone know how i can reconnect my wyze devices back to google home account again? I can use my wyze app to turn on and off the devices.


Wyze had an outage issue earlier today, so maybe that was affecting it?

I had a similar issue a while ago, but I just unlinked Wyze from my Google account then linked it up again and it worked. I don’t know why Google isn’t allowing you to unlink it. That might be something that Google support needs to help you with because they should be responsible for unlinking something. Once you get that to work, the rest should be easy to link it all back up again.

Maybe try one more time now that the outage has recovered. Then if there are still issues unlinking it, see if Google support can help unlink the service.
Let us know if you figure it out and how.

Deleted. Was appended to wrong thread.

its working now. i was able to unlink it but when i tried to link i got the error message. funny thing, went to home screen of google home and all those previous wyze devices start working again. when i went to ‘works with google’ page, i don’t see wyze home connection anymore so not sure how the stuff is working again :slight_smile:

1 Like


I guess, keep an eye on it, and let us know if there are any more problems.