Wyze Home Google home/assistant Sync

So I got one of my plugs set up. When I asked Google to sync my devices I got a wyzehome error. My Pan and 2.0 Wyze cam still show up in the Google home app. But the plug isn’t showing up in the environment.

1 Like

Unfortunately, I’m having a similar issue where I can’t sync my plugs to the Google Home client. Just got my plugs yesterday and they work fine, but I can’t get Google Home to sync and see them to use voice control. I did update the firmware, still no luck.

1 Like

Thanks for the reply. Was wondering if it was a network issue or something. Sounds like it might be a universal issue.

I really want the voice function back cause it was working with my cameras just fine but now it won’t work for voice commands either

Mine just showed up in Google home after about 5 minutes, I did not have to do anything

Odd, I wonder why I’m getting a wyzehome error when trying to since. I’ll try disconnecting my wyzehome account and then reconnecting when I get back home.

I know I have to do that with IFTTT on occasion

Just got my plugs and set them up. They appeared in my Google Home app within 10 minutes without any action on my part and voice commands are working as expected.

1 Like

Unlinking my wyzehome on Google home ,and then re linking the service fixed the issue. Problem fixed!


Confirmed. Un-linking and re-linking worked for me too. Thanks all!

Every time I sync devices I get “An error occurred while syncing Wyze Home”. Am I missing something?


Welcome to the community, @Wightly. I have moved your topic to this one as it discusses the issue you are having.

@Skullimari, I have renamed your topic because it contains the solution for most people having issues with any Wyze device Google Assistant integrations. :slight_smile:

1 Like

Every time I try to use Google assistant to control any wyze device I get "Sorry, it looks like Wyze Home is unavailable right now. " I’m not sure what the problem is. Any ideas?


@westcal98, I have moved your question here because I believe the solution you are searching is in this thread.


Just wanted to follow up to my post. After removing the Wyze service then adding it again to Google home it seems to have finally stuck. It took a few times over the course of a few months but now it’s working as it should. I still don’t know what the actual problem was that kept Google home from working with Wyze home.

Has anyone gotten down to the root cause of this?
I use google home to turn on, or off, my wyze lights with my voice. I have to do this “remove and then re-add wyze” about once a month. I have another set of smart lights (LIFX) where the only time I’ve had to do that was about a year ago.
It’s gotten old, and I would have switched them all to LIFX except that I also use the motion and door sensors to control the wyze lights also. And those always work.
So, good job on the sensors/light stuff working. But a little help on figuring out why google home doesn’t like wyze would be appreciated.