Wyze headphone won’t turn on

So I have a wyze noise canceling headphones. Before my flight today I charged my headphones and updates the firmware. I drove to airport and once I am in the plane and I realized that my headphone won’t turn on! I tried charging it it. It does lift red for couple of minutes when I put to charge then it turn green. But when I take it out, I can’t get it to turn on.

Only things that I can think of are:

  1. New firmware caused it to not work
  2. While traveling to the airport my headphones were in back wet of my car and the out side temp was 20F, so the cold somehow screwed up the battery.
    Any suggestions? Did I brick my headphone?
1 Like

I am having the same problem with my headphones. They will charge up but not power on. I have not recently upgraded them.

I have the same issue. They worked yesterday and now they did not.

Anyone find a solution. Mine won’t turn on and the ANC reset doesn’t work to reset them.

Same issue here - power button very flakey. Sometimes will power up but won’t pair, then can’t get it to power off until anc reset, sometimes won’t power on at all. They do still work with the cord.

Called support and they are shipping me a new pair. Really great service, headphones were about a month out of warranty (ordered September 2020) but no hassle at all about replacing.

I was having the same problem with my headphones. They were charged up but not power on. Recently I upgraded them with Noise cancellation Razer opus headset.