Wyze doorbell piece of junk

My doorbell hasn’t worked since it was installed. I have reinstalled it several times and I never get any notifications and it never records someone at my door. How can I fix it?

Provide as much info as possible to help with the troubleshooting process. Not working as in, no power or not getting events? What are you event recording and detection settings? Can you provide screen shots of your setup and what you’ve done so far as troubleshooting?


Doorbell doesn’t record. I never know who is at the door. It has a wifi connection but doesn’t record events, it doesn’t notify me when someone is at the door. The only thing it does is ring.

Notifications are triggered from events, so let’s figure out the events first. Need to know your event recording and detection settings to know what the camera is supposed to do, along with what it’s actually doing. Also can you provide a screen shot of the cameras view?

1 Like

Notifications are set to on and can’t tell you the detection setting because now for some reason it isn’t connected to wifi. Tried to restart doorbell but it won’t let me.

Ok, notifications are on, but again, what are your EVENT RECORDING settings? Your notification settings are not your event recording settings. Notification are triggered from events, no events - no event notifications.

You don’t have to have anything in event recording turned on for the doorbell to work as a doorbell and notify you when someone pushes the button.

Yep, I am aware. As far as I know this issue is events.

Well it won’t let me see event recording because It won’t stay connected to the internet.

Okey we will backup a step or two. What does the status light on your doorbell show? What’s your wifi network setup? How far, and what is in-between your doorbell and your wifi source? You mentioned above that your doorbell would ring but would not save events, so that’s why I started there.

1 Like

Won’t connect to wifi

“. . .won’t stay connected to the internet.” So it was set-up and does connect to WiFi & internet, sometimes.

Move WiFi hub closer to doobell to eliminate poss. that WiFi in doorbell has malfunctioned.
If it works closer, may require Repeater Bridge. e.g. GL.iNet GL-AR150 or GL-AR750S

Are you connecting using a 2.4ghz connection or 5ghz connection? Who’s your internet provider? Some providers no longer allow you to broadcast both signals with separate ID’s and if it has to be connected using 2.4 you will have to log into your router and shut off the 5ghz signal, connect your devices, then turn the 5ghz signal back on. It’ supper annoying and I don’t know why some internet providers decided to take this option away especially knowing how many Wi-Fi devices need to connect to the 2.4 signal.

Send it back or put it on Craigslist, Free stuff or Curb alert.

I hope this company never writes software for self-driving cars. I have two Pan and Scan camera that are so erratic, especially when they “update” the software. Yikes.


My advice… start over.

Take the doorbell off (by sliding upward in it’s harness), and long-press (10 sec) on the little reset tab on the back. The doorbell will give you an audible signal that it’s reset.

Delete the device out of Wyze.

Clear the cache in the phone application and force-close the application.

Setup from the beginning.

You are trying to troubleshoot ALL the problems of your doorbell. Instead, start over and ensure that everything was done correctly. All the devices Wyze makes have a pretty easy reset process if you think you messed something up. I have all of them and I’ve reset all of them.


@dzepp61510 , I would do what @Earl.Automation is recommending. One other item I would do as I did this when I set it up. However, DO NOT DO THIS WHEN HOOKING IT UP OUTSIDE. :slight_smile:

follow the steps as described above. But if possible and you are in for it, after you reset it and remove it from the app, disconnect the wires, tape the wires to keep them protected and from touching each other, and bring it inside the house near the router / WiFi. On the back there is a rubber cover, open the cover and you will see a micro USB port, plug one of the Micro USB cables into the port and attache the USB A connector into a power brick, one you use for a phone should work.

then go through the setup. This will eliminate Transformer issues, interference issues and other items. then do all of the updates and setup as you need to do. you can test it some as well. When it is working, all you need to do is unplug the cable, put the rubber backing back on and then hook it up outside.

Then see if you have issues. if you do, it is either the location or transformer. But it is not the doorbell.

Took doorbell down and threw in trash. Put up a Ring doorbell. Easy setup and works great! Now my V3 camera keeps telling me it can’t record because there isn’t a SD card inserted. Yes there is a SD card and it was working fine now for no reason it isn’t working. I can’t keep climbing up a ladder to check the SD card over and over. Wyze get your crap together before you sell to the public. Shouldn’t have to be an IT guy to set this stuff up!


That’s why Ring exists. For the segment of population that is willing to pay (A LOT) more money for technology that works most of the time. And it should, it’s 3x-4x more expensive!

Wyze is trying to do more for less. It is meant for a segment of the population that is a little less prone to just throwing something in the trash… You could re-gift it to someone who might have more patience?

I assume you are throwing your cameras in the trash next. May I have them?



No I have patience but these things shouldn’t be so hard to keep working. Just like the V3 camera. I have it wired and up on the outside of my house. I’m
70 years old and can’t be hauling a ladder out there every other day to see why my camera doesn’t recognize the SD card. It will work for a day then the next day it will say no SD card inserted🤷🏼‍♀️ I guess the saying is true…you get what you pay for. I was 80 miles from home yesterday in the middle of a lake and my doorbell rang. My phone rang and I had a picture of who it was never got that with the Wyze.