Wyze Doorbell not connecting - iOS

I got my new doorbell this week and waited until today to set it up. I have a bunch of the wyze cameras, sensors, etc so I figured it would be easy. Well, it hasn’t been easy. It will not connect. I get to the point where it asks the camera to scan the QR code. It scans it fine so I click “next.” After trying to connect for about 2 minutes it just says connection failed, retype password.

I have done the following:

  1. Verified password and verified it is a 2.4Ghz connection
  2. Rebooted iPhone
  3. Rebooted the doorbell by cycling power.
  4. Rebooted doorbell with soft reset.
  5. Rebooted doorbell with hard reset.
  6. Tried a different device (ipad instead of my iPhone)
  7. Verified I can connect other cameras at the distance my doorbell is at.
  8. Logged out of wyze app and logged back in
  9. Tried setting it up as a regular camera instead of the doorbell (someone in another thread said that worked for them).

No luck on any of it. Does anyone have any thoughts? I did submit a ticket.

Turn off mobile data and the “private network” blocking features on your phone/device.

Thanks, I am not sure where private network blocking features is located but I did try turning off cell data and even tried putting it in airplane mode with WiFi still enabled. No luck.

Worth a shot.

I had a similar problem and the solution that worked for me was to use an older iPad. I found this solution on another Wyze thread and decided to give it a try.

iPhone X 14.4
iPad Gen? 12.5.1

My doorbell had been connected but when I logged into the app and was looking for events, it has not connected since 03/31/2021 at 16:51 CDST. I have hard booted, soft booted, powered down, removed device and set up again, shut down router, logged out of app and all the other steps that have been suggested with no luck. My other cameras are working fine. I need help or this is getting returned.