Wyze Doorbell & Asus XT8 mesh wifi router

I have an existing Wyze Doorbell (the wired version).

Because of laggy internet on other devices I tried to upgrade to the highly rated ASUS Xen XT8 mesh wifi system. I can’t get it to work with my doorbell??? Any suggestions?

It tells me the QR code is incorrect when I enter the network name and password. The only hint I could find was from back in 2018 and it said to disable airtime fairness mode – I tried that and it didn’t work. I also tried it with and without 802.11x. These new wifi AP have an option to use one network name across multiple bands and they will automatically steer the device to the best band. I tried it with this feature and without it (ie, unique names for each band). Of course, I am using the 2.5ghz band and wpa2/wpa3 - personal.

Any ideas before I have to buy a new video doorbell?

The Doorbell works fine on my ASUS XT8 mesh wifi router, and @spamoni4 also has the same router and the Video Doorbell and doesn’t have any problems either, so I’m pretty confident the router itself isn’t the problem because I can confirm the device definitely works okay for me on that same router.

I do have mine set to WPA2-Personal for the authentication method. Maybe that will make a difference? I think someone told me that there are some authentication methods that won’t work for some of the devices, so if you’re using something else, maybe trying switching to WPA2 and see if that resolves it.

Also, make sure you are connecting specifically to the 2.4 gHz Band and not the 5 gHz band or that could be a problem. Maybe temporarily disable the 5gHz band while you activate the doorbell. Make sure you are connected to the 2.4gHz band on your phone, enter the SSID and password correctly and then try again.

One other thing of note…If you are running in Dark mode while trying to have your camera read a QR code, it won’t work, so if you are doing anything like Forced dark mode, end it until you’ve activated your device, then you can switch back to Forced Dark Mode. Something about the border being dark making it impossible to define and process correctly. Go back to light mode until setup is completed.

If all of the above still don’t work, I’d contact support for the full troubleshooting walkthrough. They’re pretty good about knowing what are the latest common issues for things like this and resolutions to try.

Let us know if you get it figured out.

Good choice for a router, I LOVE mine, it basically solved all my network issues.


First, thank you so much. I appreciate your detailed response and your recommendation on the router made me want to exhaust other options before I consider returning the router. I thought you might be onto something with the dark mode, but that wasn’t it. However, I believe I have figured it out.

The TL;DR version is that I think that the doorbell is faulty.

When I try to set it up the doorbell it says QR code scanned and then after a lengthy delay the doorbell says something along the lines of QR code incorrect. I’ve tried many options on the router side including changes to WPA, 802.11x, guest networks etcetera.

Then, I just realized that one of my network problems before changeover was that the wyze doorbell took over a minute to connect to livestream. I now suspect the problem is with the doorbell itself and that it is timing out before it can complete the connection.

In order to check that my network is working correctly, I remembered that I have an unopened wyze cam 3 given to me for purchasing a vacuum. I opened the V3 and it connected instantly.

So, I think my network is fine and the problem is with the doorbell timing out.

At your suggestion, I called Wyze support and I am on lengthy hold with them. I’ll keep my fingers crossed that they can fix this.

Your logical reasoning seems pretty sound to me, especially when other devices like the V3 are connecting fine.

Here’s to hoping Support is able to help you out with that :crossed_fingers: