Tried everything to get Wyze Video Doorbell to connect - keeps failing

I have two Wyze Video Doorbells (one purchased direct, one at Home Depot) - neither of them have ever been able to connect.

I’ve created a separate 2.4GHz network just for the doorbell and placed the router near the front door. I’ve tried going through Wyze support, who’s only answer seemed to be that I should try a new unit (which I’ve done - behaviour is the same).

Based on comments here, I’ve also:

  • Made sure the network is WPA2
  • Tried to manually adjust channels (1, 6, and 11)
  • Tried with and without the fuse cable
  • Tried with and without my iPhone being on the same wifi network
  • Tried with an Android phone (and my iPad, just for fun)
  • Tried printing the QR code and scanning the paper
  • Tried it at different times of day/night

I can see that the device gets on the wifi network and authenticates properly (so the SSID and password are being correctly read from the QR code). I can see that it picks up an IP address from the DHCP server in the router, but after that it just seems to stall. I’ve done Wireshark on the network, but I’m not really seeing any traffic from the device - not sure if that’s me dealing with Wireshark on 802.11 or not though. When I put a PC or my phone on the dedicated wifi network for the doorbell, they both work fine, so routing, DNS, etc. all work properly.

My wife is starting to question whether I actually have a career in IT (honestly - I do!). Can anyone suggest something I haven’t tried before I toss this in the bin and go with Ring or Google? Thanks!

UPDATE: After ranting for a bit, I looked at the default firewall settings in my cable modem/router (Hitron). The “Typical” setting blocks some P2P apps (Kazaa, bittorrent, gnutella, vuze) and that apparently gets in the way. I switched the firewall setting to “Minimum” and the doorbell connected. Now I’ll try to figure out what it specifically needs and create a custom firewall policy - this “Minimum” thing is making me a bit concerned.



@gregmilligan, I don’t know if you realize how important sharing this information is. There have been countless posts of users having issues with setting up cams and having it fail to connect. This is one more troubleshooting step that can be suggested. I’m glad you found the root of the problem. I am bookmarking your post. Thanks for sharing!


Great find! Please do share if you find out what in particular the firewall was blocking that the Wyze Doorbell needed to activate. I wonder if that can be whitelisted. I look forward to hearing if you find out what the cause is so that we can help others to not be so frustrated too.

1 Like