Wyze doorbell 4.25.1.042 (March 30 2022) - unusable/slow connection & streaming

Is an update on the current status of this issue available?

Beta firmware 4.25.1.090 seems to be vastly improved. Over the past day I only ran into one case where it hung at step 3 of 3m but the hang was much shorter than what I experienced before.

1 Like

Thanks for the heads up, 4.25.1.090 is working much better. Couple of times in the Android app it came up unable to connect quickly, retrying it connected. Not sure it that was the phone\app, but at least it connected quickly the 2nd try.

1 Like

I’m still at 4.25.1.060 and it tells me my firmware is up to date. Still having the same problems being stuck.

Here’s an update after a day or so of use:

  • the longer I use it, the more it slides back to the old habits of being stuck on step 3 of 3.
  • rebooting the device seems to fix it for a few hours

I was really hopeful this was the fix, but am not so sure anymore. I do understand that it is a beta firmware and hopefully by more people using it and sending logs they can continue to diagnose and correct the issue. It is sad that this device has been in this broken state more than a working state during my ownership period.

Edit: after the first few hours of the new beta firmware where things looked promising, I can now say that it is back to its old tricks of just not connecting. I am beyond frustrated with this thing.

Log 670693

.090 is the Beta. You have to volunteer to be in the Beta Testing program to get it.

Here is the thread where Betas report back findings:

You need to enable the ability to get beta firmware for the device in the Wyze app under account > about > beta program

1 Like

Are they deliberately using the word ‘improved’ rather than ‘fixed’? Is that a hint that we shouldn’t expect an actual fix ever?

Certainly up for intrepretation.

I wouldn’t call it improved, it’s different errors, but same result.
Only improvement i have seen, zone detection. Seems to be SLIGHTLY better, but no where near proper or fixed.
After more than 6 months, this what they come up with?

Merci’
Running 4.1.25.090 for 2days.
So far Doorbell is usable again!
Posted in doorbell beta

1 Like

Awesome! The feedback is very useful to the devs during the Beta phase.

Running 4.125.090 beta firmware for 24 hours. Same issue with connecting (step 3/3) to the app. However, the camera appears to function as expected. It still captures motion, detects people and pets, sends notifications, and the doorbell works. The live stream simply wont stay connected reliably to the app. When the app wont connect I can get it to work again by standing in front of the camera. Also, it appears to work much better early in the morning or late at night. This may indicate an issue on the server side ? Network congestion, keepalive issues ? I have three other Wyze version 2 cameras that work flawlessly.

After running 4.125.090 for a week I have observed the connection issue is between the hours of 7AM and 9PM eastern time. No problems connecting from 9PM to 7AM eastern. This is most likely not a firmware issue.

Wyze…. It’s been months with no fix. When will you decide it’s time to replace all of these doorbells with something different… offer some sort of compensation for a faulty product. A lot of us are pretty invested in this ecosystem and have been very patient waiting for a fix for this. I have a similar issue with the cam v3. Different but similar. I want to use one app… one manufacturer to make having a smart home smarter… but this doorbell issue is about to be the end. Door lock, thermostat, 4 cameras…. All will have to be replaced because of this stupid doorbell……… does this issue exist with the Doorbell Pro??

Wyze updated the app yesterday and who knows what they did with the software on their end. But my doorbell camera is magically working again this morning. Don’t know how long it will last, we’ll see. Only took a few months before it started to work. With Wyze’s less than transparent manner of dealing with issues their programmer causes I was inches away from smacking all of my Wyze stuff with a hammer and buying stuff that actually works from their competitors. Wyse really really really needs to hire at least one more programmer. The guy they currently have needs help.

I am NOT going to update the app on my end until I see what else may be broken with the update. So far it looks like the only issue is that Android users are having trouble with their screen Widget thanks to Wyze.

1 Like

Well I lied. The doorbell video is not working - again. Apparently the Wyze programmer didn’t do anything. He probably never reads the forum and doesn’t even know his crap is still broken.

Time to get the Gopro (a camera that actually works!) and my big hammer and make a video of the best thing to do with wyze crap.

1 Like

Try setting night vision from auto to on. That fixed my connectivity issues with my doorbell camera. However, the live stream will be in black and white.

1 Like

I would watch the video :joy:

I have tried night vision a few times, doesn’t work for me. The camera will connect more often, but to a static image that lasts about 30 seconds or so.

How is this still an issue?!? I was a huge promoter of Wyze, but have had to stop that entirely because of this issue. I’m remaining hopeful, but losing confidence. My doorbell is pretty much useless. By the time I get video to load, people have left my door. Never felt so punished for being an early adopter (preordered mine before release).

1 Like