WYZE Camv3 failing one after the other

I’ve had my four WYZE CamV3 for a little over a year. All four are installed indoors.
It’s been working OK, not great, but OK for most of the time.
Recently, I’ve started having problem with signal dropping. Then one of the power adapters died.
Today, there was a stolen car abandoned on my street, the engine still running. The cops asked if anyone had videos. I went to check one of my cameras, and it said MicroSD card not found. Well, there is one installed. So I tried with another card and it still didn’t work. I tried formatting the card Fat32 on my computer to no avail. That’s a pretty high rate of failure, and one that has me thinking of changing system.

1 Like

If you have not formatted the SD card with the stolen car yet, have you tried viewing the SD card from the Home Screen and clicking the View Playback button at the bottom?

You shouldn’t have formatted the SD card. The “SD card not found” error is a Wyze app bug.

Yes, I have done that. I also looked at the MicroSD card on my computer, and the last entries were from February 2024. The very last video is unreadable.

Thanks for that, but it does not help me much!
Besides, I do believe the V3 camera itself is at fault since I tried different permutations with my other cameras.