SD recording now failed on five out six cams

I have six Wyze Cams. Recording to the SD card has failed on all but one of them. Restarting the cameras and re-inserting the SD cards has not helped. There does not appear to be a new update.

Any solution to this? I am traveling from tomorrow. Investing in Wyze appears to have been a mistake.

Can you tell us what brand and model of micro SD card you’re using. That makes a big difference


They are all Sandisk 32gb A1. The cameras return more than one error in the AP when I click “view playback”. Two cameras say “SD card not installed”, even though they are installed and worked until about a week ago. Two cameras says “no video at the selected time”. And the final camera just hangs.

1 Like

I don’t think you’re using high enough quality SD cards personally. It’s suggested that you use extreme or ultra SD cards. This is what I’ve used in my four cameras and had no issues

SanDisk Extreme 32GB MicroSDHC UHS-3 Card - SDSQXAF-032G-GN6MA


I suppose that could be the case. But for what it is worth, I did test two of the cards in PC using an adapter. They both worked fine. I’m reluctant to invest in five new SD cards when the fault is more likely in the cameras – or, I’m hoping, in the software.

1 Like

Well then just try one. If you get it from Amazon and it doesn’t work you can return it

This is now the, what, fourth thread reporting this same issue. I kinda doubt all these folks’ SD cards have all failed within the last week.

To the OP, what is the
a) firmware version
b) Wyze App version

Thanks. The pan-cams are running Firmware The regular cams are running

The Wyze App version is 2.9.24

1 Like

If you haven’t already done so, and before you invest in new SD cards, try doing a FAT32 low-level format on your cards. If there really is a problem with the cards, a low-level format may be able to rebuild the file allocation table (FAT) isolating and excluding the bad spot(s) on the card. On a PC using the file explorer, navigate to the card, right click on it and select format. For your 32GB cards, select FAT32 for file system, uncheck Quick Format and click Start. Alternatively, you can download the official SD card formatter from the SD Association for use on either Windows or Mac.

1 Like

Thanks … I did reformat one card using the built-in FAT32 formatter for windows. It made no difference in the camera. Moreover, the errors are camera specific, so when I swap cards, the same camera always gives the same kind of error (either “no SD card installed” or “no video at selected time”.)

Unfortunately I am leaving town tomorrow.

The 12-sec notification videos are still helpful, but the night vision on these cameras is terrible anyway, used as they are through a window (I’ve turned off the UV lights because they just reflect on the glass), so I guess I’m done wasting time with them. One gets what one pays for. I’m going to buy some real POE cameras when I get home.

1 Like

Hmmm. My Pan is running
My v2’s are running

I’m running the WyzeBeta app, 2.9.29

I dont see the issue (as I’ve read in 3 to 4 similar threads). I can only speculate I dont see the issue because I’m running more current firmware and maybe the Beta app.

Personally, the Wyze cams I have are only for evaluation (entertainment?) purposes. For example - cams in the barn to watch the horses. one on back patio to watch for night time critters. My “real” home security cams (and home security system) are a well known brand that are 10x the price and are horribly reliable and have never faulted in the 2+ years we’ve been running them : )

1 Like

Hmm … I cannot explain why your firmware version numbers are so different. When I re-power the cameras it always seemed to update the firmware automatically, And under the iphone Wzye App menu item “Firmware Upgrade” it notes “up to date” next to each camera. Similarly, the Apple App store seems to think my WyzeApp is up to date, although it does not say “Beta” like yours.

I think you’re right that expecting to get the kind of reliability we need at $25 per camera was wishful thinking. I’m not going to be spending any more on Wyze.

Here;s the firmware status from the Wyze Cam App. It only shows four of the six cameras on a single screen.

According to this your firmware is up to date:

myswtest is probably using outdated Beta firmware since he is using a Beta version app.
Current Beta firmware is vwersion 4.x.5.111.

1 Like

I had one SD card fail so far on my 8 cams.

  1. reformat in Wyze app did not help
  2. Pulled card out of cam and quick format on PC (PC said good, cam said bad)
  3. Pulled card out and did full/deep format on PC (PC said good, cam worked!)

Who know why it happened and yes shouldn’t and shouldn’t have to pull card, etc.
BUT, try full format on PC and it might work for you like it did for me