Continuous Recording to SD Card not working

I have SD cards inserted in all of my Wyze Cams and have the settings on my Wyze app set to Continuous Recording to SD card toggled on… But whenever I open a Cam in the app, and tap “View Playback” I either get a pop-up saying “No SD card installed in camera.” or it’ll take me to the next screen but it’ll say “No video at the selected time.” Anyone know what’s up/how to fix this?

  1. How many cameras are you seeing this in?
  2. What version firmware and app?
  3. iOS or Android?
  4. Has it ever worked?
  5. Is “Local recording to micro SD” turned on?
  6. Have you tried formatting the SD card?
  7. What size SD card?

If you don’t have a card, #5 will not stay selected and you get a message.

  1. All of my cameras (which is currently 2 - 1 standard & 1 pan cam)
  2. CAM - Firmware version: & PAN - (I’m not a computer person so I don’t know if this is actually answering your question…)
  3. iOS
  4. No
  5. Yes
  6. Yes
  7. 64G

Awesome. Also, on #2, in your phone app, please click on “My Account” and then “About” and get that very hard to read number under the Wyze logo. That’s your app version number.

#7. Unfortunately, Wyze doesn’t support greater than 32gb cards, but many people have had success with 64gb cards. What brand are you using? Do you have a 32gb card you can try in the camera?

Can you take the 64gb card out and try accessing it in a laptop? It will need to be formatted as FAT32 for the camera. Formatting it in a laptop is probably the next step.

1 Like
  1. V2.0.21
    #7. I did read that, and also read that many people have had success with 64gb cards so I was hoping maybe one of them would see my post and maybe be able to help… (We mainly wanted cards larger than 32gb because we want to be able to view more than just two days back, but I guess that might not be an option now…) The 64gb card is SanDisk Ultra… I’ll have to ask my husband if we have a 32gb one that we’d be able to try… I can take the 64gb card out and put it into my desktop computer, but it’ll have to be later tonight when I get home from work.

We’ll cross our fingers that one of them chimes in. Myself, I’ve only use 32gb cards and haven’t had any issues like this. One Sandisk and several Samsung cards. Anyway, it’s beyond odd that three out of three are not working for you.

One other thing. Is wifi connected? Some have reported issues recording if wifi isn’t connected.

Going forward steps:
Try the 64 gb cards in a pc.
Try a known good 32gb card in the cameras.
Try formatting the 64gb card in a pc and then retry in a camera.

If that fails, I would go straight to Wyze support and get help. Call them, number at bottom of this page or open a ticket in the app =>My Account => Help & Feedback => Report an Issue.


Any luck with those steps?

I appear to also have experienced Wyze Cam killing SD cards. I have 32 GB cards installed in both WyzeCam 2.0 with the latest firmware. Both were operational when I first set them up, but I haven’t needed to go to the recording for several months. I tried today to make a timelapse of snow and found out that the first camera was saying no SD card was installed. Restarted camera and still reports that. Second camera is showing the same thing so I pulled out the Kingston 32 GB card from it and put it into 2 laptops and it is not identified by either, so I can’t use the SD Formatter since nothing changes.

2 cards in 2 cameras plus other reports of the cameras killing cards doesn’t give me much hope of recovering the use of these cards. I may end up buying a Wyze branded card, but disappointed that it appears to have killed 2 previously functional cards.

1 Like

I have this problem as well on my Wyze Pan camera. It was working fine for a month then recording stopped. I could not format the SD Card in the app, using the latest app and firmware. The SD card is a Kingston 32 GB card. I had to remove it and format it on a PC to get it to work again.


It killed a Wyze SD card too. All 3 of my cameras stopped recording. I doubt all 3 killed their cards at once.

1 Like

Ok is there any response with definitive answer - 'cuz I don’t see one.

I’m experiencing this same issue where the 32 GB SD card installed and formatted suddenly, seemingly for no reason, stops working - or at least so it appears to not work because in the Advanced Settins under “Local Storage” I can NOT turn on the “Local recording to micro SD Card”.

Like I said, I have a 32 GB SD card; I’ve trying formatting the SD card by using my iPhone WyzeApp and the WyzeCam, and I’ve tried by formatting through a PC (Windows). Now this feature doesn’t work again.

Just plugged in the problematic SD card into the Windows 10 PC and there’s an error message saying there was an error problem with the card and I should “scan it” but then Explorer did open to the SD card and showed me folders with files in them.

As for trouble shooting this process, I’m about to switch the problematic SD card with a new one… which doesn’t feel like a long-term solution.

the “problematic SD” - which was readable when plugged into my windows PC (though there was a read-error error message - but Explorer could read it) - was “tested” in a brand new Wyze Cam (all of my cameras have the latest firmware) - and this new WyzeCam can not seemingly detect the ‘Problematic’ SD card… I’m going to try and reformat this card (again) with my PC using FAT 32, and this time toggling off “Quick Format”, since (as mentioned above) I’ve already reformatted using both iOS/Wyze native reformatting, and Windows 10 reformatting (with “Quick Formatting” ‘on’), and try again in the newest Wyze-camera.

Update: Wow, turning off “quick formatting” really does slow things down - the reformatting of the 32 GB SD card took several hours. It’s now been in the ‘new camera’ and seems to be working as I just re-checked it again. IDK if toggling off the quick format is the trick just yet because the other times when I ‘quick formatted’ the SD, it too worked until it without warning, or knowledge to me, stopped working some point.

1 Like

It’s been a couple of days so far things with regards to this SD card issue are working fine.

I wish to note that I have/had a totally different issue (failure to take snapshots) with a different Wyzecam and I found that going to ‘Camera Setting’ (the gear icon) → “Restart Device” and restarting the the device specifically through this method fixed that issue; it’s a lesson to me (once again) that doing a software triggered restart periodically is a good practice - more so if the device is updated (‘automatically’ or manually).

I have about the same issue. My camera will not continuously record unless i have the iphone on and plugged in. if i turn the iphone off or close the app the camera stops recording. it will not work when i setup the events start and end times. i use a 32gb ssd card and formatted it using the camera. As a side note when i put the ssd card into a mac to play it back it has a bunch of 1 minuted videos. so to watch anything you have to watch each one by itself. anyway to increase this from 1 minute to something else? so if i want to leave the house and want to record how do i do that? cannot keep the iphone on the whole time.

I haven’t seen a fix in this post? When my SD card runs out of space instead of it incrementally overwriting it just wipes the whole SD card. So now I keep ending up with no data by the time I come to change cards… Seems this started happening with latest Firmware update. Thanks

I completely agree. My pancam was fully recording to SD card before the latest update. Now its stops recording with 0/0 left on the card. Reboot and nothing is on the card. Completely empty. I have tried 2 different cards. My other WYZE camera records continuously but it is not a PANCAM. Also, the firmware is different. This camera is 2 months old and worked perfectly before the update. Somebody needs to find an answer soon. This thread along with others is growing too long and difficult to read.

These types of problems can be frustrating. The fact that many of the ones reported in this thread deal with cams/cards they have been working but now after periods of continuous use start to have problems makes the use of High Endurance Cards more believable. I have had these types of problems and have been slowly switching my cams to them with a noticeable lack of problems.
My routine has been, so far, to switch or start with These Cards (although there are many available) and to pre-format even new ones using this recommended Format Program.
Apparently the older cards, not designed for the constant write/rewrite cycles of video, will not hold up as well or as long and will eventually develop problems.

If the theory is true then why is my old card working perfectly and a card I just put in the PANCAM this week - NOT working properly? In other words, it records about a day and a half - then stops and reads 0/0. I just bought this card to replace a card that was about a month old. I have a dashcam that has been using the same card for about 4 years. The old card - less than a month old - did the exact same thing. If they should work for 7000 hrs that’s 292 days before they create BAD files not ZERO files. When I REBOOT the camera the card magically reappears as empty. No files. There is more to this than High Endurance cards. This may be a heat related issue or a firmware issue. The problem only occurs on my PANCAM. I have a WYCAM V2 as well. No issues with it and was using the same exact card.

1 Like

Is the Pan set to pan and tilt? I have one too, but I only use those features manually, so those motors are rarely used.

However, I can’t imagine a Pan would be rotating and tilting so much to produce that much heat.

You wrote

I’ve read two other threads with this same issue, so maybe the recent update introduced this issue.

I’d say submit an trouble ticket

Motors are set to manual movement. I tried the follow method and it was moving all over the place.