Wyze cams with Tinycam pro only work on wifi and not mobile data

Hi Wyze cam community,

This is my first post and first problem encountered with Wyze cam using Tinycam pro. I’ve been using the Wyze cams for about 6 months and they have been great. I use Tinycam Pro to view them and has been working fine for 6 months or so.

For the past month or two, I noticed that Wyze cam video feed would only work when my phone is on my home wifi and not mobile data. Wyze cam app works on both. I’ve made no change to the wifi router settings and Tinycam pro, I don’t think Wyze cam would need port forwarding either.
I’d only get kb/s on Tinycam pro feed and 0 fps. As soon as I put my phone on the home wifi and I’ll see the videos. I should mention that the Wyze cams are on the guest network and my phone are on the 5ghz regular wifi network.

Has anyone encounter this problem? Anyone have any advice on how I can trouble shoot this problem? Thanks so much in advance.


#3 should address your question?

I cannot access my cams from mobile network, but they work with local WiFi connection. What are the required steps to enable broadcasting?

You need to setup port forwarding on your router. Port forwarding forwards all traffic from your private camera to external network, e.g. from to your_external_ip:8080 . Read the router manual for how to do that or contact your system network administrator. Enter your external IP address and port number in tinyCam Monitor when you’ve done.


I’ve find it that TinycamPro sometimes work and sometimes doesn’t without me changing anything. I’m not sure if this is a router thing or the Wyze cam server issue that is causing this.

Try closing the Wyze app. Then turn OFF the Wifi on your phone. Now, make sure the cellular data is on for your phone and then open the Wyze app If success, then it’s your phone service not the Wyze app. Try NOT wifi on 5 Mhz. My Wyze app works perfectly using cellular service.

I didn’t notice what OS you are on, but if it is iOS then check Settings > Cellular, scroll to the bottom and look for any apps that could affect this, and has the cellular switch set to ‘off’, like Tinycam Pro or Wyze. Same thing for Android if there is such a thing there.