Wyze Cams cannot connect when on Mobile Data Network

Yes, I have checked all these things. It worked a few times without wifi connection and the just stopped. I update my software regularly too. It hasn’t worked for quite a while.
It always tell me to check the camera’s connection to wifi. It tells me the camera has lost connection, but the camera always works fine - it’s the connection to my phone through the app that is lost.

Check this setting… from your iPhone: Settings > your name at top > iCloud > Private Relay > toggle feature Off

1 Like

EVERYONE WITH AN IPHONE-this was 100% the issue. Thank you so much for the solution!

1 Like

I just got new cameras that are working great. I honestly cannot find ‘private relay’ or toggle on my settings. .

@elisabeth6551 Private Relay is on the phone not the cameras. Open the settings on your phone. Tap your name on top where it says Apple ID, iCloud and open the page. Scroll down toward the bottom you will find private relay. I’ve had mine turned on for a few years without any issues.


Got it.

I was looking on my phone - but I looked down lower with your info. and found it. Turned it off. Will see if it makes a difference.

I did get new cameras that are working great. I needed them while I couldn’t get this one to work. But good to know.

I was told by Wyze customer service that you cannot access the camera with a phone plan (need WiFi) & then told my phone plan wasn’t compatible. I gave up - it got frustrating.

But I will try this out. Thank you.

I’ve been using my iPhone SE2020 for over three years to view my WYZE cams on both Verizon Cell Data from anyplace in the country and Wi-Fi when available. I know that some members have had issues using Cell Data on T-Mobile.
The cameras need to be set up on Wi-Fi and your phone needs to be on the same Wi-Fi network during set up but after that you can use cell data all day long if required to view your cams.

Maybe with this adjustment, but I did the set up properly and have not been able to access the cameras without a WiFi connection on my phone.

Hi newbie here, I can’t access cam v3 thru mobile network, TMobile on Samsung Flip 3. I did connectivity test and passed. I am looking for solution.

1 Like

Do you use a VPN or anything similar on mobile? If so. Try disabling it.

I gave up and have new cameras that are great. Wasted money.

1 Like

I just tested it over T-Mobile (well Boost Infinite with a T-Mobile provisioned SIM card).
I do NOT use a VPN, and it works well.
Sometimes it works better than my home Xfinity Cable Internet service!

If you don’t mind me asking…
What brand/model cameras did you go with?
Thanks!

I did not use VPN.
What brand/model of your phone?

Pixel 6a with all Android 14 security updates through February 2024 and Wyze app at 2.49.1 (390) and firmware on ALL devices to current (no beta firmware nor app in use).

I do have other problems:
Stuttering playback on the Event Viewer for Cam+ when “record sound” is off under advanced settings (V3 and V3 Pro cameras only). 4x playback helps with this issue.

V3 Pro cameras have problems connecting over Wi-Fi occasionally (have to toggle Airplane mode ON/OFF on my phone). You may want to try toggling Airplane mode ON/OFF next time it will not connect, it only takes about 5 seconds to try.

Best of luck!

Thank you. It is working now after I did an update on Wyze apps.

1 Like

I just bought Blink to be sure I can rely on the cameras