Wyze Cams break my network?

I’ve got a bit of a problem.

I have two V2 Wyze Cams, two Amazon Echo’s, and a couple smart plugs.
EDIT TO ADD: Firmware for the cams is
Cable Modem/Router ARRIS - Model: TG3452A/CG
I’m using a 2.4 network for these items.
I have an iPhone XR

So I got my cameras on Friday and set up was a breeze. After a couple hours the cameras said they were “offline,” Alexa said she couldn’t connect to the internet, and my iPhone said the password for the network was incorrect.

I went into my router settings and see that everything was the same. I reset the router. Still can’t connect anything to the 2.4 and it doesn’t appear to be broadcasting even though on my router portal it says it is. I figure out a small hack - I change the name of the 2.4 network and reconnect all devices - this seems to fix my issue. And I continue on my merry way. A couple hours later the same thing happens! And I go back into my router, change the 2.4 name to something else, save it, then change it back again - presto - it works again without have to “set up” everything again!

Then it does it for a 3rd time yesterday. I contact my ISP, they run diagnostics and can’t find the issue. I contact WYZE support and they walk me through the “RouteThis Helps” app. Once I rename my network again it works fine. So the network was up and running for the RouteThis to run because otherwise it wouldn’t connect and be usable.

I wake up this afternoon to find that my 2.4 network is doing the same thing and that all connected devices are offline. It did work for the duration of my 12 hour night shift and I was able to check in at home during the night. I do the rename thing once again and get it working again for about 1.5 hours when it craps out again. I’ve now reset everything and have left the cameras unplugged.

Is it possible that the cameras (or the app) are “crashing” my network? How would a person fix this issue? I’m not horribly techy, but can work stuff out with the aid of google…


What kind of router do you have?


Model: TG3452A/CG

This may be very dumb but try it at a neighbors house who has a different router and bring one echo over there. I know it is a pain but…
If Arris was provided by your telecom internet provider that might be an issue. I have an Arris cable modem and a Sagemcom router that Spectrum provided. The Sagemcom is junk. I will get rid of it some day but I do have a higher powered router downstairs connected to it. At times I have found that Spectrum (Time Warner) resets all my settings which includes the wifi names, channels and more…

Peter–the above is just a guess.


Have you tried changing the password on your WiFi during any of this? Failing an electronically flaky router, which your ISP should swap out, it almost sounds like you could have been hacked and somebody is playing games.
Just an off-off-off the wall guess!


Thanks for the replies thus far. I’ve contacted our ISP again and will have a tech come out next week. I’ll try your suggestions in the mean time!


ISP routers tend to suck.

Buy your own router, that allows you much more control, and it will be cheaper in the long run.


Thanks for the suggestion. My ISP provides a modem/router combo. I’ve also read about putting the unit into bridge mode in order to run your own router - is this what you’d suggest? I was looking online for stand-alone modem and router options but with being in Canada I’m not sure what modem would work - I noticed on Amazon that the modems will let you know what providers they work for but it’s all for US bases ISPs.

I just added an Amazon Eero to my ISP provided modem/router. It was child’s play to do and it has solved the vast majority of the cam problems I was having. Bridging is an option but I have not done it yet because initially I wanted to test the Eero with a just a couple of devices. It has worked so well just connected to the Isp box that I haven’t bothered to fine tune by bridging. I’m running two wifi’s side-by-side and using the Isp box as a modem. Pushing 60 devices and life is good (so far!)

1 Like