V2 cameras all stopped working

Last summer after coming back from a short vacation I noticed all my Wyze V2 cameras (4) mysteriously stopped working.
I tried for a long time to get them working. I did a factory reset multiple times and have had no luck at all. I could understand one of them going bad but all four at once, I don’t think so.
I have held on to them until now. I just tried doing another factory reset on them again with no luck.

Let me explain the steps that I am doing:

  1. Making sure that my phones Wi-Fi is connected to my 2.4G network.
  2. I did the factory reset for 10 seconds, I can feel something switch on and off in the camera when I do this. Then I heard the Ready to Connect message.
  3. I got to Wyze app and added a new device. Picking Wyze Cam.
  4. I clicked on the Next button on my phone, and it asked me to pick the network. I picked the same 2.4G network that my phone is connected to.
  5. The bar code does scan and I get the message, “You are code scanned please wait”. The Blue light does flash on the back.
  6. Now I get the message, “Cannot connect to local network”.

Since this happened last year, I have purchased four Wyze V3 cameras and they all were able to connect properly and are working. There is something that changed in the V2 that is preventing them from connecting to the network. Right now, I have four V2 cams that are worthless.

Does anyone have any advice?

It almost sounds like the v2 cameras are connecting to your wireless network, but the wireless network does not have outside internet connectivity to the wyze servers.

If that’s not the case - given your v3 cameras are working - did maybe a firmware upgrade to your v2 cameras fail?

I’ll be honest - the cam v2 are crap compared to the v3 anyway.

I’d try taking them to another location - friends’ house - and try to set them up on your friends’ wifi and see what happens.

Also try to reset them by holding down the button or whatever during boot-up.

I don’t have any advice, unfortunately. I had the same thing happen with mine. One stopped working and shortly after, my other one did too. Repeatedly tried the same steps that you had taken and nothing worked.
Wondering if you have an update on your situation… any luck getting them to work?

Editing to add: I also have v3 cameras that have been working fine. It’s just my two v2 cameras that stopped working.

Something to try…change the passphrase on your WiFi network to something short and sweet that does not end with a space. Try connecting the V2s once that is done. If they connect, then it is safe to say your passphrase contains characters the v2 does not like or is simply too long. If that does not resolve the problem, simply put the passphrase back to its original setting such that your v3’s come back online.

Good luck!