Wyze Cam v3 won't power up properly

I have a Wyze Cam v3 that used to work fine, but now it won’t start up. When power is first connected, the cam makes a click, but nothing else. No status light is lit. The “SETUP” button does nothing, even if held in for 15 seconds. No microSD card is installed. Is the cam toast, or can I revive it somehow?

1 Like

First thing I would try is a different power source.

1 Like

Yes, I’ve tried multiple different power sources and power cables. Same result. The camera does make an audible click, from which I infer it is indeed receiving power.

2 Likes

Power supplies can be cranky - but it sounds like you already did what I had suggested. They can sort of work which makes it look like they are working, but only sort of.

I got a good example of a cranky power supply last week. The ONT for my fiber Internet was re-booting somewhat regularly. So Frontier came out and replaced the ONT. Couple hours later the replacement ONT started rebooting. So they came out again and based on me being a technician who has seen stuff and what I observed, I suggested that it may be the power supply - even though it appeared to be working most of the time. Sure enough it’s now three days and my Internet is working perfectly. So cranky power supply it was…

1 Like

If you cannot do the basics, it sounds toasted. Maybe let it sit while you order a replacement.