Camera bricked


after a power outage my V3 cam did not come back online, i assumed it had some connection problems.
After taking it down and trying to reset it, turns out it does nothing anymore, also the led does no light up. The camera is only 2 months old… I guess it is broken? Or does anyone have an idea i could still try?


Are you using the included cable and power adapter?

Sometimes power outages can cause sudden spikes in power that can damage electronics, but generally they are fine.

Are you not seeing any light at all even right when plugging it in? Can you try a different cable and power adapter?

1 Like


thanks for your reply. I have tried both; the camera on another cable/adapter,
and another camera on this cable/adapter.
I bought a 3 set, so i could just change them out to test.
The other camera works fine on the cable/adapter of the one that was not working.
The broken one also does nothing on the cable/adapter of the other.

Using the original USB cord, and Samsung usb powerplugs.

I am not seeing any light, i tried multiple times to keep holding the power button,
nothing happens, no sound, no light…

Welcome to the Wyze User Community Forum @Roy_L! :raising_hand_man:

If you aren’t getting any status lights or activity when it is plugged into a new cord and power adapter, it sounds like a candidate for a Warranty Return.

Contact Customer Support to get that started.


FYI, I had to replace a V3 under warrantee (about a month before it ended), and the process was very fast and easy.
Had the replacement in just a couple days.


I was just hoping that there was something i could do to fix it, without having to go for warranty.
I come from The Netherlands, so for the price of non-business shipping,
(around 30-50 euro) i can just order a new one, which i knew up front, so that lies with me.
Wyze cams just got good reviews, that i decided to order them, instead of a local option.

Thanks a lot for all the replies :slight_smile:

1 Like

If the power outage did not fry any electronic part inside the camera, you could try a manual firmware flash. If the firmware got corrupted during the outage, this may bring it back to life.


Thanks, for the reply, I checked it out, but its not doing anything, so i also cannot flash it.