Wyze Cam v2 will not stay connected.

I have 5 v2 cameras and they all stream for a few minutes or seconds and then they disconnect. I have tried two different 2.4 networks with a strong signal and it doesn’t seem to matter. They won’t stay connected 10ft. from the router. I have 7 wifi cameras of a different brand and they stay connected without a problem. The other brand cameras, however, have db gain antennas. Has anyone else experienced this kind of issue?


Reply on 5.26.18

I just received three V2 cameras and am experiencing the identical problem. I just a minute ago tried a reset with just one of the cameras. The camera “voice” said that setup was successful. I immediately checked via the app on my iPhone and it was not live streaming.

I have a strong signal from my router; didn’t lose it until I walked a block away from my house.

I sent in a message to Support about this two days ago but have received no reply.

I telephoned support yesterday, was told by an automated voice that I was third in line for a tech, and was put on hold with Muzak for about 15 minutes when the automated voice stated there were no techs available and I was disconnected.

Many owners are having this same problem. The company has a bug they haven’t yet figured out and it has rendered the V2 cameras non-functional. I hope for the sake of the company they get this sorted out as I want them to succeed in business.



I just received 2 cameras and one works fine and the other is experiencing exactly this issue. Please provide an update on what to do and I have emailed support as well.


This is happening to me as well BUT I am able to go to Notifications and then see up to date clips of what my Wyze camera have recorded.

So despite me not being able to connect to live stream, I can still view clips that may only been captured a few minutes earlier.

1 Like

Close. I received 3 V2s Tuesday. 2 set up with no problems. 3rd on is a no go. Connects, did the version upgrade, but freezes after 2 seconds. And when it goes for longer than that, the lag is like 5 seconds. Then freezes again. I do know that when I went into Alert Settings, I could not turn on Motion Detection. It would say “Operation Failed”. Re-flashed, rebooted, etc. I had 2 V1s that one of them I had to toss cause it stopped connecting. Now I get 3 and one is a dud. 60% success rate. If this were baseball, batting .600 would be enough to make me the richest dude in baseball. But this ain’t baseball. I want something that works.

I’ve used this forum for questions before. I would get a response, but no one ever follows up to the followup questions.

1 Like

I just posted a similar issue last night and just found this post and a similar post this morning. So far with this post, the other post and my experience there seems to be a connection issue with having 2 or more Wyze cams on the WLAN. I’m not sure if the Wyze cam is streaming so much data that it is cause network congestion or what.

My theory is that at the same time it is throwing traffic on the WLAN that it is also sending additional traffic out to the WAN that may be causing the issue. I’m hoping this isn’t the case when you have an SD card inserted and recording locally instead of sending that same traffic to the cloud. But 2 of my 3 Wyze cams have SD cards and it seems to still be an issue.

1 Like

Bandwidth for both the Wyze cameras from 6/1 to 6/7. Sucking more bandwidth then I would have thought. No idea on what is happening with the one called “sidecamera2”.

Adding 2 more should be interesting.

1 Like

Similar issue here. I have 2 WyzeCam Pans and A WyzeCam V2 that I just got at a local MicroCenter this past weekend. The Pans finally seem to work right (after much tinkering), but only when on two different networks. I have two routers, one running off the other via LAN cable, with a few different SSIDs between them. I added the WyzeCam V2 this weekend and at first had no issue. The V2 lost power last night and upon restarting (multiple times to try to alleviate the issue) the app can connect but only shows about a second then freezes for a few seconds and disconnects. When using TinyCam I get a similar experience. It connects, shows about 1 second and then freezes for about 10 seconds, disconnects, and starts the same over again. Meanwhile, the Pans are working fine.

1 Like

So… even more confusing… No one is home, therefore no one using streaming or messing with my network, and my 2 Pans, as mentioned above continued to work fine while the V2 was acting totally crazy. Five hours after my V2 was restarted via the handy dandy WiFi switch I have it on, it suddenly started broadcasting normally. The fact that it worked TERRIBLY after a reboot and took 5 hours to normalize while the Pans worked fine with one of them on the same network as the V2 makes me think there’s something wrong either with the V2 cam or the firmware on it. I’m on the Beta, so not sure if it would be worth switching to the mainstream version and downgrading the camera firmware or not.

EDIT: Arrgghhh… It’s like they take turns glitching out. I had been watching my V2 for 20 minutes or so where it had finally started streaming pretty smooth, and suddenly one of my Pans started glitching and showing about 1 second then freezing and then eventually reconnecting and doing the same thing repeatedly, just like the V2 did for several hours. As I said, no one is home so there’s no one streaming and far fewer devices connected to the network than usual. It all worked perfectly fine yesterday.

1 Like

Having similar issues to you all. I have one Wyze cam and one Wyze Pan cam and both take turns being on for a short amount of time, then freezing and showing the “connecting camera” and “authenticating” messaging before going back online for a very short time. Then the cycle just continues all day. I have fast wifi connection and both are about 15-20 feet from the router.The KB/s keeps dropping to 0, then it stops updating. Very odd but I hope it can be fixed as I rely on these for security.

1 Like

Ya know, after slipping and bumping my head while standing on my toilet to hang a clock, I wanted to see what would happen if I connected it straight to the router. It works. Don’t know for how long. But, it connected.

I only have one camera and I cannot view the live feed after running all night. It cannot “Authenticate” The error says to shut the App down, but this doesn’t work.

Apparently, the camera is still connected to wifi and records fine during the night.

The problem can be solved by shutting the camera down and re-powering it. This is unacceptable.

I fixed the problem by plugging the camera into a Kasa Smart Plug and scheduling it to shutdown for 2 minutes and start back up. Once at 9:00 pm and once at 5:00 am.

So far this allows me to “Authenticate” and view the camera live feed in the morning with no problems.

The problem seems to be a time issue as only scheduling one shutdown at 9:00 pm didn’t solve the problem and only after scheduling the second shutdown was the issue resolved.

1 Like

I own 15 Wyze Cams and they are constantly experiencing connect issues. It’s so frustrating, I unplug them, reboot from app, etc. and nothing and I mean nothing helps Wyze must fix this serious flaw with their cameras.

It’s a possibility you are having issues because you are hitting a device connection limitation with your router. I had a Nighthawk R7000, and as I started adding more IoT devices to it, I started having connection issues. I checked the Netgear forums and support articles, and found out there was a 32 device limitation with each band (2.4 and 5 Ghz). I would highly recommend researching your router to see if you are experiencing an issue like that. Some older routers just aren’t made to to used in a smart home.

Hi, I wanted to send you a heartfelt "Thank You " for all of your wonderful assistance with my connection issues. You were correct, I had to go into my router settings and denote my 2.4 Network from my 5 Network. Moreover, Comcast automatically provides customers a “guest” Network. This is so you don’t have to give your guests your passport but, it is setup on the 2.4 Network so it was helping to dilute my signal. Most importantly,

I was able to find some great quality wifi boosters and I purchased two and once connected my Wyze devices not only came back on line but, the connection to them is lightening quick! I just purchased more of them to ensure that I will not have this issue again. I am once again excited about my Wyze products and can’t wait until my bulbs get here to try them out. Thank you so very, very much.

1 Like

Which WiFi booster did you purchase? I am having the same issue and I have Comcast.

Hi, you can find the one that I have here:
but, I posted my reply too soon. This morning my cameras went offline again the only difference today is that they did come back which is usually because they typically do not. It has been hit and miss all day which is super frustrating especially after all of the money that I have spent. I may have to return my products and seek cameras and sensors that will operate on a 5hgz network.

Thank you. I agree, if the issue continues, I will purchase another brand.

1 Like

Just updated the Firmware update as of 9/24 and now cannot cannot Wyze app to camera with error 90 no internet connection. I unplugged both the camera and internet router and still didn’t work.

I am now experiencing this same problem. I have two Wyze cams, I believe they were fine until I upgraded to the current version of the IOS app. I am also using the beta firmware that allows for RSTP and the cams are falling off Blueiris as well. I have a WIFI extender in the same room as on of the cameras but that isn’t helping