Wyze Cam V2 w/RTSP firmware all video inverted and changing it in the app reverts to invert in seconds

I have 4 wyze cam v2’s still running the RTSP firmware. In the last week or 2 all of them inverted the video feed (none are mounted upside down). Switching it in the app (which displays it as not rotated) by turning rotation on and then off again fixes it till I leave the camera and come back. This is not only in the app but in the RTSP stream. It’s all 4 cameras but not affecting my PanTilt or my Og cameras. Just wondering if I’m the only one that has the issue. Seems really like the settings are not being saved or over-ridden remotely by Wyze.

To add to it I have removed the app, tried the beta version, tried 2 different android devices none will fix the rotation issue.

Have you tried power cycling the cameras? Probably won’t make any difference but easy enough to try.

Rebooted, with and without sdcard, rtsp on and off, its as if the setting doesnt update in the cloud so as soon as i browse away it reverts to those settings. For it to happen to all the same version of camera with the same firmware at the same time tells me the problem isnt hardware.