Wyze Cam Pan RTSP

I’ve been trying to upgrade my wye cam pan to the RTSP firmware and when holding the setup button I get the “Ready to connect” prompt. I downloaded the firmware unzipped and named it demo.bin. Could there be something I’m doing wrong?

Hello and welcome to the Wyze Community.

Here is a link to setting up RTSP. I had the same thing happen and came to find out that I was not holding the setup button when plugging in the USB cable.

I’ve followed the instructions exactly, when holding the button when plugging in after a few seconds it starts rotating, then gives the ready to connect prompt.

A couple of things to check -
Is the SD card 32GB or less and formatted as FAT32?
When you name the firmware do you make sure you are viewing the extension?
Windows will rename a binary file and put the .bin extension on it so you end up with demo.bin.bin

So it has to be 32 or less cause I’ve been using a 128gb micro sd

Sometimes they work, sometimes they don’t. But 32GB is what Wyze sells.

I use a 8Gb… and have same issue.
Used this same card on a V2 and works perfect. (I was loading the new RTSP fw)

Also, I tried to save videos files at camera…and SD card works fine inside camera.

Only my PAN is not willing to cooperate.

Remove USB power, insert card with demo.bin (yes not using the V2 fw that is different) power usb… I get that yelowish blue for a short period of time… and then yellow fix and puff… does nothing.

Meaning, I go to the app, and see no change on fw version, see no option on rtsp… while on V2 it did what was supposed to do.


I think I am pressing the button to the maximum… so is there a way to check if button pressed or not? does it “blink” differently?


I am having the exact same issue, just wondering if you ever figured it out?
I know the Setup button works, as I can use it to enter ‘Ready to connect’ mode.

Its like it just refuses to enter the firmware update routine. Would be helpful if we knew a little more about what checks are done where maybe during the bootup process?

I was having the same issues (yes I see this thread is 8mo old but it had no positive reply so…) but fixed it because I was using FAT and exFat I believe - forcing FAT32 fixed my issues.

I had the same issue… thought it was the SD card size (come on Wyze, why are you stuck in 2010?), but had the issue with pathetic 32GB cards also.

THE FIX: Remove the SD card, do a reset so that the cam has gone into reconnect mode. Unplug the cam. Then insert the SD card with the properly formatted (FAT32) and file naming convention (demo.bin). Hold the reset button, plug in the cam. After a few seconds (5-10) you’ll get the blue light (blue-yellow combo). Let go of the reset button and let it do its thing. It’ll reset once complete and you can re-add it to your app.

MOD NOTE: Post edited to conform to the Community Guidelines.

I followed these steps and tried several combinations, sd card formats, sizes etc.

Is there any official comment on this?
V2 works fine - pan cams have problems with the rtsp firmware.

Thanks in advance

Hi Walter, did you try my method above? I did have troubles with the Pan as well; it took a few more reset attempts before it took.

The thing needs a bootloader mode that can be triggered from the app prior to reboot… or something similar.

Thanks for the quick reply.

I tried 3 different SD cards - 2 x 16 GB and 1x 8 GB
formatted them with macos from disk utility to FAT, later via the MACOS CLI to FAT32, then I tried it via windows10, mad sure there are no hidden files on it light .spotlight or other autocreated files - with all three cards.
I tried with and without prior factory reset.
Running out of ideas :frowning:

It worked with two of the V2s on first try, so I tried all of my above mentioned steps despite being sure my card and method of preparation was correct.

But you are giving me hope that you just needed more attempts. Did you change anything for these attempts?

The only other thing that I could think of was to make sure that they are up to the current mainstream firmware before switching to the RTSP.

Other than that, you appear to be doing everything correctly. I’ve done this with all sorts of SD cards, from 32GB to 400GB, and it has worked.