Wyze Cam not reading sdcard after firmware update?

Hello, I just received two Wyze Cams. Upon setting up the first cam after downloading the app, I received a notification that a firmware upgrade was available so I went ahead and installed it. The cam set up properly. However, I cannot get it to detect the Samsung EVO 32 gig card. I’ve tried unplugging the cam after installing the card and still no luck. I’ve also tried formatting the card on a pc and still no luck. I tried a second card (both were purchased brand new with the cams) and still the cam won’t detect them.

I then set up the second cam, but this time, upon being prompted of the firmware update, I decided to skip it. I can confirm both sdcards work without issue in the second cam. Even tried both cards in the first cam without any luck. So it appears the issue is with the first cam itself or the firmware. Can anyone advise on possible next steps please? Thank you.

If that doesn’t work I would recommend contacting Wyze Support with this link


1 Like

Check if your units are covered by this:

1 Like

So I had the same problem with my Wyze Cam v2 and a friend that bought one as well. What I ended up doing to fix my issue was installed the Wyze app on my phone and connected to the camera as a normal security camera. Inside the app I went to to advanced settings>local storage and formatted my sdcard from here. I also made sure to eject the sdcard using the app. Then I put the sdcard back into my computer and copied over the firmware. I then put the sdcard in my camera and while holding the reset button connected power. This allowed my camera and my friends camera to boot to the sdcard and install the firmware. By the way, I successfully used a 64GB sdcard to do this so the camera will work with a 64GB sdcard.