Wyze Cam Floodlight won't manually update firmware

Wyze Cam Floodlight (not V2 or Pro according to box), which I’m reading uses the Cam V3 firmware.

After a remote firmware update last fall it would no longer connect to the network.

Trying to update the firmware using a 32GB FAT32 card with just the demo_wcv3.bin file on it.

Powered off, insert SD card, power on. Lights alternate blue/red (no purple) for a few seconds then steady red. Hold Setup button for awhile. I only get Ready to Connect. No indication it is recognizing the firmware on the card or the need to update. It is adding videos to the card, which I have wiped. Have repeated this several times now with the same results.

You need to hold on setup button prior to turning on the power. If you don’t have someone else to help you to turn off the power, then you will need to pull out the USB cable connecting to the floodlight and hold on to the setup button and plug it back in.

If it is too difficult to plug it back into the floodlight while holding down the setup, then you can plug it into an external power bank temporary. Alternatively, you can remove the Cam V3 from the floodlight as there’s just a screw at the base of the Cam V3 and do the same steps above.

It seems that you are trying to flash a V3 firmware to a floodlight. You shouldn’t; the floodlight has its own firmware.

The bare floodlight has a firmware from 2021 that has never been updated. It also has a V3 camera attached, which has had many updates.

Thanks, I will have to see if I can reach the switch with a coat hangar or borrow a neighbor.

They need to update their instructions. Nowhere is that clarification about power-on made clear. Also the USB cable made no sense at first, but I understand now. Although I’m not sure that mine unplugs. There is no disconnect visible from the outside, unless you need to remove a cover.

That doesn’t mean V3 firmware works with the floodlight. Did Wyze support tell you to do that?

Yes, under the FAQ for the Wyze Cam Floodlight. Very last item. "Wyze Cam Floodlight includes a Wyze Cam v3. "

That doesn’t say the firmware is interchangeable. It simply means it uses a V3 camera with an expanded function (read, new firmware!) to control a floodlight.

Yeah the short cable fits snuggly into the Floodlight is removable. I didn’t know it was removable until I searched the forums and I had to flash 10 different firmware to test which firmware fixes the audio playback issue. The latest 9357 beta firmware doesn’t fix this issue either. In fact, the latest beta firmware cripples the V3 even more as shown here

Any firmware after 4.36.9.139 will have audio playback issues as noted here. According to Wyze, next firmware update should address this problem.

Tried again today. Empty 32GB FAT32 card with nothing but the firmware on it. Power off, USB unplugged. Power on, holding setup button, USB plugged in. Red light, after 10 sec it flashes red/blue and then I get the Ready to Connect message. It’s not trying to update the firmware.

Weird. I just manually flashed V3 to 7095 firmware just now and it worked. I held the setup button and then powered it on. I kept holding on the setup button even after it turned purple for like 10 seconds and then I let go of it. It turned red afterwards and I hear a click sound I’m guessing it is restarting to the bootloader to flash the firmware. After 2 to 3 minutes, I see V3 online with the 7095 firmware.

He’s not flashing a V3 camera; he’s flashing a floodlight with a cam V3 firmware and expecting it to work.

It’s the same thing as they use the same firmware. I flashed my Floodlight “V1” camera (one with the V3 attached) camera numerous of times when I was trying to debug another issue.

In fact, I just flashed my Floodlight V1 just now with the same method using V3 firmware because I wanted to go back to 8391 firmware (it was previously on 9357 beta)

There are 2 distinct devices in a Wyze Cam Floodlight. You get a menu option when doing the connect setup. The floodlight firmware cannot be updated and has never had any updates anyways if you look through the site.

FYI, my floodlight power is hooked up to a light switch. Here is my step by step of what I did earlier today:

  1. I turned off the light switch and inserted a 2GB micro SD card (with the firmware you want) into the V3.
  2. I hold on to the setup button first and then I turn on the light switch for power. Within 5 seconds, the LED light turns purple, but I keep holding it for another 10 seconds for safe measure and then I let go of the setup button.
  3. I wait approximate 5 minute or so for the firmware to finish flashing just to be safe.
  4. The V3 goes online and it shows the correct firmware within the Settings > Device Info page on the app.
  5. I remove the 2GB microSD and I insert back my 128GB microSD for continuous recording.

May I know which firmware you wish to flash? According to Wyze’s instructions, if you go back to firmware 4.36.9.139 or below then you need to do the factory reset process.

I also have mine run from a light switch.

I am following the same steps as you. I have never seen the purple light. It always goes solid red, red/blue flash to “Ready to Connect” within 15 seconds.

I’ve also done the factory reset process. No card, hold Setup. Same result…“Ready to Connect”, never a reset.

I put the latest firmware on the card. 4.36.11.8391

That is strange. If it can’t even reset, then it is possible your setup button is faulty and it can’t be held on. Sorta like a computer mouse’s microswitch double clicking when you are just trying to drag some folders.

I don’t know what you can do. You can try swapping the V3, but you’ll probably need to remove rubber from the Micro USB connector in order to connect to the Floodlight. It’s very tight fit. You’ll need to remember which direction to plug it in too. I personally have never swapped the V3 on the Floodlight before so YMMV.