Wyze cam 3 connects after manual flash but after power cycle won't respond

Wyze cam stopped responding, most likely after a firmware update. Showed a solid red light. After attempting the other recommended troubleshooting steps, I attempted a manual firmware flash using a 32gb microSD card, holding the setup button while connecting until light turned purple. This seemed to be successful – the camera went through some different light status indications and eventually connected to the app, responding normally. But, whenever the power is disconnected and turned back on, the camera won’t respond again – solid red light retuns. I can go through the process of manually flashing again and get it to reconnect, but this isn’t practical since the camera is mounted in an out-of-the way location and it’s obviously a hassle to have to put in a clean SD card with firmware and hold down the setup button every time there’s a power disruption. Tried a couple of different firmware revisions (one current and one substantially older), same result.

Any suggestions as to what might allow the camera to reboot normally without a new manual flash every time? Went through the web troubleshooter which ended with an email to Wyze support, but the response came back that it was no longer eligible for warranty replacement, etc. It would be dissapointing if the camera is effectively “bricked” even though it is at least temporarily recoverable…

Thanks for any input you can provide.

1 Like

Hi @electroplatebah and welcome to the community.

You said to get it running again you manually flashed firmware onto it and it would work until power is interrupted. Can you tell me what firmware version you are flashing into the camera?