Wyze bulb timing based rules not working - Dec 20, 2020

Having this same issue still. Glad to see I’m not the only one…


Any rules with time delay are broken.


I’m seeing this too. Yet another issue plaguing Wyze users. Oh, and a camera that I manually turned off in the Wyze app with much difficulty this weekend, turned itself back on without any indication it had done so, resulting in lots of footage of my me and my family inhabiting the living room.

But I’m sure the good folks at Wyze are spending more time introducing a slew of new products and services – instead of solving the issues the rest of us experience…

I always notice those cam ‘denials of control’ also. It’s almost like the schedule/event backlog fights the manual power button. Another design oversight.

Good new S-O-P would be for them purge event backlogs PRIOR to restoring service. What good are actuations from the past when we wanna live in the present?

Why isn’t this fixed yet? All my time based rules aren’t working still. Who is trusting Wyze enough to buy their thermostats etc at this point.

Interesting subject. I recently (12/2) opened a ticket with Wyze Support because my Scheduled Rules are acting a bit weird. They fire on average of 2 to 4 minutes late. In addition to the delay, when you look in the Rules History, I will have multiple entries for one rule indicating succeeded. Wonder if this is related.

For Example: The lights come on and off after scheduled time. The Rules History shows the following (All as succeeded) - Notice the first trigger is shows 5:06pm succeeded, but the rule is set to run at 5:01pm.:

   > Plug on and off: 5:06pm Succeeded
   > Plug on and off: 5:08pm Succeeded
   > Plug on and off: 5:09pm Succeeded
   > Plug on and off: 5:10pm Succeeded

This all got fixed earlier btw…

I think we got them fix now…

1 Like

I can confirm, my timing based rules are working correctly again. Thanks for fixing things Wyze!

For anyone else still following this, I had to unlink Wyze from Google Home as well yesterday because Google Home couldn’t find any Wyze device. After re-adding Wyze, things appear to be working again as expected.

1 Like

I tried to use the time of day on, time of day off rules but couldn’t find out if they are working or not. Seems my Wyze bulb only stays connected to my WiFi network for about a day until I see the little cloud with the cross out icon on my home page. I’m ready to go back to just using it as an expensive LED bulb using the wall switch to control it. To bad because I could use more of these bulbs in my outbuildings.

Even if you program it correctly, it goes on and off randomly. Spent a lot of time setting up a schedule, but the issue is not resolved. It does not follow the schedule.

I had this same issue where bulbs that should turn off after motion sensor cleared for 30 seconds were not. I recreated the rules and they’re working again.

Might try updating the firmware if you haven’t already.