Wyze Bulb & Alexa

I just set up the new Wyze Bulbs and tried to use them with Alexa, but it does not find them. I have the Wyze Smart Home Skill enabled on the Alexa app, my Wyze cameras show up, but not the bulbs. Any suggestions or advice would be appreciated. Thanks, Kerry


Im having the same issue. I was able to set up one camera and the other one I wasn’t able to either. I get the “No devices found” after trying to use the “discover device” feature on the Alexa app.

1 Like

I’ve had that happen with all kinds of smart home devices. Restarting the device and waiting for awhile before doing discovery again usually fixes it.

Also having the same issue

Tried WrecksO’s solution. Unfortunately, it did not work. Thanks for the suggestion. Other suggestions most welcome.

Just noticed my wyze sensors are offline now that I have set up 2 wyze bulbs am I the only one with this issue

1 Like

Having the same issue with the bulbs and Alexa. Using both IOS and Andriod Alexa app, Neither find the bulbs. Tried the restart as well. Firmware


I setup one bulb and it wasn’t detected in the Alexa app however I called aloud “Alexa, turn off Laundry room light” and she turned it off for me. Is the Alexa app/Wyze skill supposed to be able to auto-discover the light bulbs or did it actually find it, but display “no new devices found” as a glitch?

Got alexa to finally discover the wyze bulbs by disabling the wyze skill and then enable the skill all is well now


Thanks for data point. Did the same and now have them showing up in Alexa. Added a third, and it was discovered immediately.

Strange I got the same no devices found, but Alexa recognized the light bulb anyway. Must be a UI glitch where it is actually discovered, but displays no new devices found instead. Maybe someone else could just calling aloud to turn theirs on after Alexa app doesn’t detect it and see if theirs is added anyway like mine was?

Thanks to rmblaster1, disabling and enabling the Wyze Skill worked for me.

1 Like

Signing on to say that " rmblaster1 " suggestion worked for me also.

Disabling and then enabling again worked for me. Thank you.

@rmblaster1 worked like a charm. Disable and enable skill worked right away

Glad I found this thread!

Bulbs arrived Fri.

Before installing bulbs, I installed the latest version of the wyze app.

Then I installed the bulbs according to pkg directions!

Alexa could not find my bulbs! So researched n found a different set of installation steps. In the help section?

Still no luck!

Then I found this thread! So I enabled n disabled the Wyse skill. Still no luck!

Then I said to myself check for any updated bulb firmware, Found it, upgraded it, still no luck!

Then I said, check for Alexa app updates, too!
Found them n updated, Alexa!

Then I enabled a new version of their Wyse skill, on alexa! Then Success finally, happened !!!

Now all is well !!!
Thx people!

I continue to get Wyze-r !I

Wyze Can - Wyze Sense - Wyse Bulbs !!!
The Wyze-r - The Better !

1 Like

So, I was able to get the bulbs working and the Alexa App can see them. I can use them through the app, but I cannot use them with voice commands through Alexa. Any suggestions on how to correct this?

You should be able to use voice commands through your Alexa devices. Have you tried to disable the Wyze skill and then re-enable it? This might cause the voice commands to work. I have no problem with using any of my Alexa devices to turn the bulbs off and on or to dim or brighten them. Kerry

1 Like

What he said

Thanks! This worked for me too.