Alexa does not work with Wyze devices

Hello all,

First time posting. I have an issue where Alexa does not see any of my Wyze bulbs, cameras, basically any Wyze devices.

This issue started over 6 months ago. I contacted Wyze support and was told that my account is experiencing a known issue and that it has been escalated to the developers for resolution. And that someone would be contacting me back.

This was over 2 months ago now and nothing. I love Wyze products but I am so disappointed in their support.

I cannot use any of my Wyze devices with Alexa. I have unlinked and relinked my Wyze account from Alexa with no success. Anyone had this issue and resolved it? I clearly need help with this and Wyze don’t care to help.

Welcome to the user-to-user forum, @mattssteel!

Did they give you a ticket number? This is our only way to track what happened.

Thanks! :slight_smile:


Are they showing up in the Alexa app under all devices, just not responsive? Have they ever worked, and just suddenly stopped?

Have you tried deleting the unresponsive devices (if they are there) and trying to add them again (have Alexa discover devices)?

1 Like

Create a new account.

Hi IEatBeans,

Yes they used to work, and for a long time. Then about 6 months ago devices started disappearing. They all went away when I unlinked from Alexa and relinked. Alexa never finds any new devices now when I relinked.

Also if I go into Wyze app and look under firmware updates it tell me I do not have any devices on my account. Yet they are all there in my devices list.

Hi Sam_Bam, I have considered that but can I move my subscriptions to the new account?

Yes it is ticket number 2346104

Cost you nothing to create and try - just try a new account. See if that solves the problem. THEN, talk to Tech Spt or Cus Service about moving or crediting the subs.

Is your account the owner of these devices, or are they shared to you? In the device live view, go to settings, and take a screenshot.

My account is the owner of about 90% of the devices. I have a few shared devices from another account.

That’s strange, I would try contacting support, it seems your account is very messed up.

If it’s easier to just create a new account and set everything back up like suggested above, go ahead and give that a try :slight_smile:

So, I checked with support, you cannot move subscriptions. You have to cancel and resubscribe. They have given me a few more things to try, basically remove and re-add all my devices and see if that resolved the issue. Not really a great solution, but will try.

Matt Steel