Wyze battery cam pro connection issues

My wyze battery cam pro has been a problem ever since I got it. It barely connects to network and now it won’t even try. I hate every thing about it from the device to product support.

Is it just me?
I have already rebooted the device, even deleted it and re installed it. The app and firmware is up to date. I even bought a wifi extender just for the camera. I’m out of options right now. The support is not helping at all but forwarding long emails to trouble shoot.


I was getting that “Failed to connect Network error” (android app) last night on my new Battery Cam Pro (fully updated and 90+% charged). I gave up thinking I would go out and pull the battery to reboot it later, but in the morning it was working. I did not do anything.
I have no idea what is going on. The Wi-Fi signal is good there too.
I really just bought it to scare animals out of the flower bed, but I have not setup a rule yet to turn on the alarm if it senses motion (I would like it to be more stable before doing that). I put this camera into my doorbell camera group, which may be part of the problem, I don’t know.


I have the exact problem as lawrenceboya. I have a suspicion that it is related to a recent firmware update. It says “network error” yet it is clearly connected to the wireless router. Everything is operational (it can record/detect events, etc.) except for the live view feature. I have removed the power source for more than 10s, rebooted, and still no live view. I was going to delete the device and re-add it but saw this posting.


Getting the same thing here on 3 battery cameras that had their firmware updated. Have pulled battery and reinstalled. No change. Everything seems to work except live view.

1 Like

These are the three tricks I employ to get the V3 Pro and Battery Cam Pro into SINGLE Live view when getting stuck on this screen:

Loading Live Stream
Step 1 of 3
Starting up a secure Connection

Usually one of these 3 hacks will fix it!
Close the Wyze app and Toggle Airplane Mode at the Android level. Go back into the Wyze app and see if it will connect.
While on the hung Live View, press the HOME button (middle circular button at the bottom of Android screen) then press the Recent Tasks button (square one on the right bottom) then select the Wyze App, gets it back. I use the 3 button navigation NOT Gestures. I am not sure how to do it with gestures enabled, maybe just swiping up? This is usually the fastest of the three!
Close the Wyze app, and clear the app cache at the Android level, and restart phone.
Go back into the Wyze app and see if it will connect.

My V3 Pros (3 of them), and my brand new Battery Cam Pro are the only cameras that exhibit this bizarre behavior. You can always see the V3 Pro streams from GROUP camera view , it just balks when you try to do a SINGLE VIEW Live stream.

Most of the time Toggling Airplane Mode at the Android level is my “go to” solution, and it is only temporary (may last a couple of hours).

I do NOT think this is an acknowledged problem yet (not on Fix-It Friday).
It is a general nuisance for me, and does not seem to affect my spouse’s Pixel 8. It happens frequently on my Pixel 6a (both phones on Android 14 at February 2024 Security level, current Wyze production app 2.49.4(402), and all firmware at current levels). I use the Light Theme, and “Enable Hardware Decoder” is OFF in App settings.

Some just sign out of the app, clear the cache, and sign back into the app to fix it.
Some people have even resorted to uninstalling the Wyze app then re-installing it.
I hope they find a solution at some point.

1 Like

My Wyze battery cam had been working for weeks and suddenly stopped around the time of the Wyze data problem. Wyze sent an email saying I wasn’t affected but my camera coincidentally stopped working.

Anyway, after wasting an hour recharging, rebooting and fiddling with the app, the problem turned out to be the wyze app. Once I cleared both cache and storage and did a force stop of the app, then logged back in after mfa text and password, the thing works again. A bunch of settings were lost, so yeah, but at least the camera works again. :eye-roll-here:

1 Like

probably wyze support helped you, nothing wrong with app.
i use wyze app on many devices, it would be a lot of hassle follow steps you described

I have 10 or 12 cameras. Only 3 of which are the battery cam. And these are the ones that are having the problem. All others work fine.

1 Like

Still having the issues after unplugging. Removing battery. Removing camera and re-adding it. Both cam pro’s not working. Any updates or other options to try?

So has anyone had any success? I’ve tried everything that you all have mentioned in the above nine replies and I still can’t get this camera to connect. This is the only one that I have a problem with but it’s also my only battery powered camara in wyze. I’m at the point where I’ll just admit I’m out the money and just buy a more reliable brand

Has anyone fixed theirs? I have 2 wyze battery cam pros and 2 v3’s. The V3’s are working just fine. Both battery cam pros are recording events, detecting motion but won’t connect live at all, which is ok for what I bought them for but not the best. Would love to find out how to fix it. Since it obviously isn’t a WiFi connection issue as they are working since they record…

Something is definitely wrong with the Battery Cam Pro. I requested a replacement camera but it only worked for two days and I’m back to the same problem, "Failed to connect. Error code: (code - 5).

It is only the battery cam pro failing to connect, my other two wyze cam v2 are working just fine.

I am really considering to switch to a different brand even if it’ll cost me more.

1 Like

Still no luck here, it’s disappointing.

Unfortunately this did not work for me. I’m still getting the same problem after I clearing my cache and app data.

Same here. More information. This only affects my BCP cameras and only on my Samsung Galaxy Fold 4 phone. All software is the latest. I get thumbnails and events, but no live stream, just the error above. The same cameras work with my wife’s iPhone. With my Samsung Galaxy Tab, when I select the BCP, I get a button to press “Play” to start the live stream. Once I press that button, it works. It is unfortunately that we are getting the typical Wyze crickets and the occasional fanboy/girl trying to blame the users.

I have my battery cam pro in a group with my Doorbell cameras (two VDV1 and 1 Pro).
I was having problems when I clicked on the
“Tap to start live stream”
button too. It would just finally timeout.
Even when it did work before the outage, it took almost 9 seconds to fully get in.

What cleared it up for me temporarily was to log out of the Wyze app.
Clear the Wyze App cache at the Android level (not from within the Wyze app).
I then logged into my Wyze account on my Android 14 Pixel 6a, and it showed the live stream after about 9 seconds.

I know this does not work for everyone!
If you have tried everything, I would call Wyze and get a ticket# and submit logs.
This is one of the most expensive cameras they offer, and so it should work!

1 Like

Success ! Thank you muerte33

Logged out of the Wyze app.
Cleared the Wyze App cache at the Android level (not from within the Wyze app).

To clear your app’s cache and data:

  1. Open your device’s Settings app.
  2. Tap Apps. See All Apps.
  3. Tap the app.
  4. Tap Storage & cache Clear cache or Clear storage.

I then logged into my Wyze account on my Android 14 Pixel 6a, and it showed the live stream after about 9 seconds.

Had the same problem. It’s worked on webview but not in the app. I logged out of the app and logged back in and it started working.

For anyone who is having the -5 error code, try using the restart button in the cameras settings. If it fails to restart, try removing the battery.

If this doesn’t work try logging out and back into the app.

Please let me know if this helps at all.

Same issue. Pro battery cam showing failed to connect. Network error. But the camera works showing all the motion detects. It’s up to date on firmware and I have tried clearing the cache after closing the app and restarting phone. Also tried restart camera and taking battery out. It’s the only camera with this issue and it’s pissing me off! How can I rely on this for the safety of my home? No answers from customer support? Sounds like I need to start searching for a more reliable company that stands by their product.