Wyze Band out of sync, Cannot delete

My Wyze Band went out of battery. After charging, I cannot sync it with my app. I am unsure if it is an issue with my band or app. Tried rebooting band and reinstalling app. As a last result, I reseted the band. I thought I would start over. But when I try to delete the band, The app won’t let me. It throws some JSON error and won’t let me delete. Any ideas how to fix it?

@wzeuser Welcome to the Wyze community! I’m guessing this may be the pairing code to add the band. If it is you will need to confirm the binding again. Take a look at the support article below.

Before I get to add a new band, I need to first remove the band from my Account. I can’t get past that.

In the Wyze app if you go to Wyze Band, three dots (…) top right, More, it won’t let you Remove Device at the bottom?

Right. Once I confirmed Removed, it throws “Net deviceDelete Err: -1”

Restarting your device make any difference?

@ArthurH do you have any suggestions? I haven’t seen this error before.

Tried rebooting phone. Tried reboot band. Tried reinstalling app. Finally tried reset band and here I am. Potentially, I can register the band with another account. But I want to keep using my band under the same account!

I understand. Only thing I can recommend now is to call support. Really strange behavior.

Wyze Customer Service

1 (206) 339-9646

Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT


Tried today. Not much help from them.

Just FYI, I found out my app is not up-to-date. I updated my app but it is now worse,

I can’t even get to the “…” page of Wyze Band. With my old app, I can at least reach the “…” or “More” page. Now, I cannot even get to the “Remove Device” button at all. The App is constantly trying to Connect to a band that has already been reset. I think my problem can be solved if only I can remove the band from my account.

BTW, I managed to screenshot the error message prior to update. It says:

Net deviceDelete Err: -1(Delete Device Err, Please try again.)

followed by a JSON object. I don’t have a screenshot. It says something like ts: , mode: 1000, something

Probably best to start a support ticket so this issue can be resolved. Post your ticket number from the support email here afterwards.

Submit a Request

Finally figured out on my own. To remove the device, I need to let the new app sit there until it gives up Connecting to the band (about a min). Then I can click that “…” and remove. After that, I am able to add and pair the band again.

This solution no longer work. It will not delete the device unless it can connect to it. This is absurd.