Wyze Band Notification (Android)

I haven’t seen this covered yet so I apologize if this already was.

I do not own a Wyze Band, but in the last few days a notification bar on upper left corner of my phone reads “Band connection is running” and doesn’t go away. Not clickable either.

Tips anyone?

Bump – Anyone?? lol

I’ll assume you’re using an Android 9 or 10 phone…

Pull down the status bar from top of screen.
Long press the notification.
Turn off this undesired notification by tapping the on/off toggle.


Go to system settings.
Open Apps.
Scroll down to Wyze and open it.
Open Notifications.
Turn off “DownChannelService” and “WyzeBandService” by tapping the on/off toggles.

And you may wish to restart your phone after doing this.


Thank you friend!

Applied method #1 I wasn’t sure if “DownChannelService” was critical to have for other non-band related updates or notifications.

1 Like

No prob… glad to be of help. :+1:

1 Like

“DownChannelService” is related to the Alexa service.

1 Like

Thanks for clarifying :pray: