Wyze Band Data not syncing Beta App

Looking for assistance with Wyze Band. The band seems to be tracking data. Steps are showing. Sleep data shows. However, the data is not syncing over to the app. I have reset bluetooth. Rebooted band. Forced stopping app and restarting band and app. When i got into app, it says its syncing at top. And completes that task. But when i click on activity in the app, no data shows. I am on beta app. And all firmware is up to date.

1 Like

I just got mine a week ago and has the same issue this week. I didn’t check in with the app for the last two days and when I did this morning, I wasn’t able to sync the data from the last two days. I am hoping someone has a solution to it. My firmware is also up to date. I use android. Data are showing on my band but not in the app.

Same problem here.

Not on the Beta app, but having the same problem on both Wyze Bands* - info shows on the band, but does not display Steps or Calories on the app! We have booted phones and bands but still nothing.
*Mine and my husband’s - same on both our phones!

Yep, same here. It started “losing” data on Monday. I have submitted a ticket and logs, but so far no solution seems to be on horizon. I have had the problem on iOS App (both Beta and Released versions). I have also tried, reboot, reset, BT cycling, etc. and nothing has reversed the problem. Unfortunate when the main function of the device (to track steps) doesn’t work, but this appears to be a complete sync outage…no steps, heartbeat, calories. For awhile, I just assumed I had died and didn’t realize it, but no…its either the band or the app! :grinning:

Mine stopped syncing to the activity page Wednesday evening. It’s like a big black hole with WYZE on this issue, nothing. Submitted log and images but no response. It’s hard to like when there is only a one sided relationship. I’m not on the beta app.

Well I had a chat session with them and took them thru what I was experiencing. The agent I worked with was polite and understanding, but wasn’t able to determine what was going on and said she was turning it over to their SW team to look at. That was yesterday. Came here today to learn others having same issue. Overall, the band has been a much less satisfactory experience than I’ve had with the cameras I own.

@mped - Just a note that WYZE does not use these forums to solve any issues that I am aware of. Have to contact support to get help from them…if they can. On this issue ( see below) they have no solution yet, based on my experience.

same here

Same here, android, up to date. Sync 100%, records activity during day, doesn’t update to band. Lost all week. Since I input steps to WW app, very annoying. Ready to go back to Fitbit.

Just an update, This morning the Band started syncing with the App, including the Activities Page. Then the Band stopped tracking steps, HR, etc. No history updated from Thursday to Saturday. Reset the Band and reinstalled it on the App. Nothing, no step history update, not tracking current steps. As I type this I notice the App history is gone. Just recently vanished (like within the last 10 min).

Of course nothing from Wyze on the submitted support ticket.

I know Wyze doesn’t use the Forums for issues, but appreciate the opportunity to vent.

As bad as I hate FB, I may try a Charge 4.

1 Like

Mine worked for 1 day. Have data for yesterday. And thats it.

Hi guys I have the solution directly from Wyze Support!

Try and return the Wyze Band to Amazon. That’s right. That was the support agent’s suggestion. Even though it’s past the return window. (Of course Amazon directs you to Wyze once the window has closed.)

Why aren’t the features advertised working, I asked. Engineers will look at the logs and try and make improvements. I don’t consider making essential (and advertised) features work correctly as “improvements” but that’s what Wyze thinks. If you’re in the Amazon return window, RETURN IT NOW AND RUN FAR AWAY.

…and mine captured part of yesterday. In fact when I look at the daily Heart Rate data, I can see it captured from about 11AM to noon (CDT) yesterday and then restarted capturing data from 11AM today until present time (I think).

This is making me think that the transfer of data from the watch to the application, must involve more than just a local WIFI or BT connection, but rather, go thru some servers on WYZE end. Otherwise, why would several of us be seeing similar performance and outages? If my hypothesis is correct, the problem is the WYZE servers and not the devices or application themselves. But I could be very incorrect on those assumptions. Wouldn’t it be wonderful if someone from WYZE would simply let us know what is going on?

1 Like

Same here. I assumed it was a short February bug rolling into March bug. But it looks bigger than that and has been going on for multiple days for people.

Craziest thing ever! The band started capturing data again and, for me, it has filled in all of the missing days worth of data. No firmware update. No application update. It must be something going on at WYZE. Which also means they are also capturing all of our fitness data on their servers, which is not terribly surprising.

Same here. All caught up. However, seems like the Band syncs to the App in stages. Right now my Band shows 11,012 steps, the App shows 11,012 steps, but steps in the 7 and 30 day view show 10,904. Always behind. At times even the 7 and 30 day view are different. Submitted logs and screen shots, but no answer. Fitbit keeps server data as well. At times my wife’s Fitbit one stops syncing and then just starts up again.

@djandra Good to know yours is working again, as well. I have noticed that the sync routines are a little disjointed as you mentioned. I attributed some of that to power management, particularly with the band which has a pretty small battery. I was unaware that similar issues occur with FitBit, as I’ve never owned one.

Had the same problem. Wish I had checked here first, because I reset my band and now can’t use it all. SO FRUSTRATING

@Kelleyz I also tried resetting my band, but had no problem re initializing it. What happened after you reset the band? Does it not even turn on? Your should be able to re-establish a connection to the app just like it was new. In fact, when I did mine, I did not even lose the data.

I totally agree that this product has been very frustrating and the lack of support from WYZE makes it even more so!