Wyze Band App Activity Screens stopped updating

As of about 1:30 pm yesterday, the app stopped updating the data graphics on the activity pages, and also the periodic heart rate page graph is also not updating data, it’s just a blank page…Which was where I could see at what time this started since the Heart rate graph just stops at 1:30 yesterday.

The activity and heart data show on the band itself, just no longer on the phone app detail pages. The main screen graphic on the app for “activity” shows/reflects the correct steps, sleep and heart the band itself does, but the app’s activity detail pages do not. They spin a little saying loading, but stop and all show a blank page that show no data… steps, sleep, heart, etc. All no data and blank pages.

I’ve rebooted the Band a ton of times, removed the band and added it back, cleared caches, force stopped the app a bunch of times, turned blutooth off and force quit the app and restarted both, restarted the phone, just about everything I can think of. The only two things I haven’t tried are actually removing the app and reinstalling, or clearing the actual memory (not just cache) of the app… reason being I don’t want to have to reset all my cams, bulbs and sensors rules if I can avoid that for obvious reasons.

And I’m not sure… if I remove the app, and reinstall or clear the app’s memory, if I actually would have to redo the entire setup from scratch again? That’s something I’ve wondered about for a while.

Any Ideas or advice?

1 Like

This exact same thing happened to me as of 10-ish am yesterday. Tried everything you have. Same results. Still not working.

1 Like

Oh wow. That’s interesting. Wonder if anyone else too. Would seem likely…I’m still hoping that once it goes into tomorrow something will change, but I’m not so sure. Thanks for commenting btw.

Same thing here. No activities sync to the app as of yesterday.

I am having the same issues.
Not syncing any activities from band to the app since yesterday (11 July Sat.)
I bought this band two weeks ago from Amazon. I am going to wait a week to get it to resolve, else returning it.

My band stopped sending data around 6:30 PM EST 7/11/20 for steps, heart rate, and sleep. I did get about an hours worth of steps and heart rate to send Sunday morning after rebooting the band. Two odd things is the Activity icon in the app shows the same data numbers as the icon on the band. And the Run data (that’s not on the icon) did transfer to the app. I opened a Support tkt with the log and am waiting on a reply.

So far I’ve lost two nights of sleep (data) over this.

It is a common issue going around.

strong text

Same here. Last step count showing on the Wyze app my iPhone XR is from Friday, 7/10. No step count recorded on the iPhone app 7/11 nor 7/12.
As a work-around, I take a screenshot of my step count before I go to bed each night, if I remember.

Same Here, No info synced since Friday.

Whenever third party integration comes around we could probably have better results when it comes to keeping track of results.

Same issue, initially app would error out on sync, the press again to sync will say successful, however when I go to Activity tab it does not show any activities, walk/sleep/HR or Calories.

I have had same problem with no solution.

Same issue here. Band seems to have the info. But its not updating the app. Honestly i really wish they would just put something solid together with this band. Nothing but constant issues with connectivity with mine Android or my wifes Apple. Its more work just getting this thing to constantly keep working. About ready to just get rid of them. Just not worth it.

I have had the same issue July 12 and 13. Is this a software issue or operating system issue. Makes you wonder about the new wireless cam.
An additional note;
about 10 AM. july 13 my band and smart phone started communicating again. no idea what triggered it.

Do you know if there is a wyze app for the windows pc?

Mine is back as of July 13 midnight. No data for the 12th though.

Yes, same as WendyV for me, back at midnight the 13th

.A comment or two here seem to suggest theirs may still be not working, and some others had a longer dispruption than I experienced. Hard to say if it’s problem solved, or, it’s just working for the moment…

OK as of 10 minutes ago July 13th data came back, but no data for 11th and 12th.

Wyze has been working on a cloud issue on their end.


They just made a post about it here as well…Wyze Band Cloud Issue - 7/10/20