Wyze Band missing data for 2 days now

Has anyone else been experiencing this problem? I use my Wyze Band constantly. Today I noticed that it has recorded NO data for Steps, Calories, or Heartbeat (but Sleep data IS there) from Tuesday onward. I’ve tried rebooting the band & the phone but neither worked. My Wyze Band says its firmware is up to date. I don’t know if my Android Wyze app needs to be updated or not, but I see nothing on any menu within the app that would allow me to check to see if it was the most recent app build. The Band part of the app says “troubleshoot” and it supposedly lets you “send a log file” but pressing Send gives me no indication that anything happens when I hit send. So I assume nothing is being sent. Anyone else have this issue?


I am having the same problem as Emperor3. No data was recorded since February 23, 2021. In my case, the sleep data was not recorded, either. I’ve tried rebooting both the band and my phone without success. The activities seem accurate for today (February 25th) but when I go to review them tomorrow morning, they will be gone. What else can I do? I am using a Samsung S7 phone and have two Wyze cameras that are working perfectly with it. The Band has worked perfectly with my phone until now.

Turns out my sleep data also stopped being recorded. Even though I can SEE the numbers when looking at the Activity tab on my Band, they do not show up on the Activity area of my phone’s app. I called “support” which turned out to be a male with such a thick Indian accent that we both had to repeat words to each other multiple times, sometimes using phonetic spelling. I was told to restart my band (which I had already done), then to uninstall the band & reinstall it (didn’t work) then to go to the Play store to download an updated version 2.17.41 (my Samsung Galaxy 6 currently has v.2.17.7) but a new version was NOT found on the Play store. The CSR was perplexed at this. He said he would send me an email (which never arrived) that I could reply to. After we hung up without resolving the issue, I uninstalled the Wyze app and reinstalled it, hoping to get v.2.17.41 but that didn’t happen. The old version was reinstalled. I suspect the problem is that my phone being a Samsung Galaxy v6 is the reason it does not detect that there is a newer version of the Wyze app for Android.

Anyway, this issue is STILL not fixed, even after speaking with customer support.

WyzeGwendolyn can you please look into this?

One other strange occurrence that may be related… On Tuesday 2/25/21 my Wyze scale said I lost ~15 Lbs in one day. Not very credible, so I re-weighed and it was the same. Next day those 15 Lbs returned. I’m betting this was related somehow to the issue with my App no longer pulling Activity data from the Band. Today I notice that my “heartbeat” data stopped at 1400hrs yesterday. Odd…since I had my heart removed when I joined the Army. :slight_smile:


Same issue here. No Activity data being transferred to the app starting on Tuesday, 02/23/2021.
Heart rate data (different tab or function) still transfers.

Wyze app has been updated to the most current version (v2.17.7), and the Band is also up to date (

I’ve also rebooted both the band and phone, but to no avail.

Any input WYZE?

Same problem here - neither my nor my husband’s Wyze Band has displayed Steps or Calories in the app. Everything is up-to-date. I noticed this same problem was reported last year (July) but no response regarding an actual fix! Band isn’t very useful if you need to copy all the info out manually every day!

And suddenly they started working again this morning. I have 2 Band’s attached to 2 different Android phones. Both stopped working at the same time and started working again at the same time.
My 2 cents…the App software has a problem with February. The only month that is less than 30 days.

My Wyze Band synced with my phone today (March 1, 2021) for the first time in a week. I think that dougnpams is right. The program is having a problem with February’s being a short month. I hope that’s fixed before I get the Wyze Watches I have on preorder.

Have same issue with my two bands, Stopped displaying activities last Sunday (Feb 21st) Activities synced and displayed yesterday but today (Monday the 1st) problem has returned. Workout activity is displaying but nothing else. I have tried everything but no luck. Very frustrating as Wyze support does not seem to care. I think may be a cloud issue that may be related to the recent maintenance of the Wyze cloud assets. I wish Wyze would fix asap otherwise bands are useless.

Well…my App is STILL not pulling Activity data from my Band. (See screeenshot) As you can see, it stopped early on Tuesday 2/23/21 and never returned. Same goes for Calories, Sleep, Heart. It isn’t back this week either. There is a LONG bar for every Activity on Sunday of this week ONLY, but still no data for Monday or Today. I called Wyze Support and spoke with a male who has a thick India/Pakistan accent, who told me I don’t have the latest version of the App, which was put out…wait for it…on TUESDAY. Well, he said he would send me an email which never arrived. I also never got any “ticket number” from him. At this point I don’t know what I need to do next.
Its frustrating…

UPDATE: Today I noticed that there IS data if I only look at the “Monthly View” but not if I look at the “weekly view” there’s one long bar for Sunday and nothing for Monday onward… And when I spoke with Support, my app version was not the same as the latest. Today it IS showing the latest build, but it still having issues.

UPDATE#2: Today (3/3/21) I see that everything is back working again AND the missing data from last week is now showing. Not sure why it glitched last week, and no idea why its suddenly working again. The same numbers showing on my Band are also showing on my phone app., and increasing throughout the day. Weekly & Monthly views are both correctly displaying. No explanation from Wyze… but its back working correctly.

I’m having the same issue. Sunday’s total was about 6000 steps short on the weekly view and Monday and Tuesday (so far) are blank. Yet the Monthly view has an accurate number for Sunday. Although it now looks like Monday and Tuesday did not correctly update on the Monthly view. Last month it looks like the monthly view stopped recording data on the 24th and the weekly view on the 23rd.

1 Like

UPDATE: I concur with Emporer3 update. Although I do have the latest version of the app as I uninstalled and reinstalled the app yesterday. Problem still present but noticed that if I flip between the 30 day view to the 7 day view the data briefly appears correctly in the 7 day view but disappears (some strange magic going on) Also noticed that last week’s missing data has now appeared. This week still showing only data for Sunday. Very strange but something is seriously wrong with the app. Please fix!

1 Like

I’m not only missing data on my sleep monthly view, but they have changed the sleep font today, making it even worse to read. All the others appear to be improved, but they chose an out of sync hollowed out font on the sleep. Those are always more difficult to read. Now, they larger, it is worse to read. Who is making these decisions?
Wow! Notice the comparison of the weekly font on STEPS compared to the weekly SLEEP FONT. The monthly SLEEP PAGE IS to show the missing data. There should be 5 more nights there.