Wyze App Fails on Google Pixel Phone

Just got a Pixel 3A XL phone. Loaded the Wyze app along with all my other apps. When launching the Wyze app, I get the initial green screen. But, then, it goes black and the app never finishes launching. Anyone know a fix for this? Is the Wyze app not compatible with the Google phone?

Maybe try to uninstall and reinstall it. The wyze app is compatible with Google phones. Otherwise, you may need to contact tech support.

1 Like

The first thing I did was reboot the phone. The second thing I did was uninstall, restart the phone, and reinstall the app. No joy.

When opened a support ticket, I gave the version number of the app. I had to find it by going into the Android Settings, because the app crashed when I try to open it. I entered the app version and submitted my help request.

Then, I received a “canned” auto response that suggest I check the app version and update if one was available. What? Later in the response email, I was advised to open the app to check the app version number.

The whole reason I opened a support ticket is because I can’t open the app. In this case, support failed miserably. I don’t think a human ever looked at the support request. If they can’t do better than that, I will have purchased my last Wyze product.

MOD NOTE: Post edited to conform to the Community Guidelines

I have a Pixel3 XL and it works fine on my phone. I track 3 wyze cameras with mine. I’d ask what OS you have but mine has worked with all versions since I got my 3 XL almost a year ago. The wyze app version on my phone is 2.7.19. My phone OS version is Android 10 and the last update was Dec. 5th.

I hope you get some joy soon…they really do work on Pixel phones.

1 Like

I’m glad to know the Wyze app works on your Pixel 3 XL. The graphics chip is different on the 3A version phones. Maybe that’s the difference. I dunno. I have the same version (v2.7.19) on my phone. It tries to launch, but then goes dark and does nothing. If necessary, I will keep opening new support tickets until they know me by name.

What is the app version you are trying to use, and what is the OS version on the phone?
I know you have already provided this information to support, but we don’t have access to that information here. I’m also curious if you are using the public release or beta. Have you also tried Google Pixel support to find out if they have seen similar issues?

He has the latest app v2.7.19 on his phone. Not sure which Android version he has. It’s strange it doesn’t work. I haven’t experienced it before on the pixel 3a on Android 10 with v2.7.19. I think there are other users that have the pixel 3a but I haven’t seen this issue.

Finally, success! After the fourth install, it finally works (knock on wood!). As before, I delete the app, shut the phone down, restarted the phone, reloaded the Wyze app. This time, I shut the phone down again and restarted before trying to use the Wyze app. I don’t know if that was actually a factor, or not. In any event, the Wyze app now seems to be working properly.

Thanks for checking in on this topic. I feel like I got more support from the community than I did from the manufacturer. From a consumer perspective, that’s rather sad. I will cut Wyze a little slack simply due to the proximity to the Xmas holiday and the fact that the support request was on a weekend. But, if the support response I got from Wyze is the standard, it is a serious shortcoming in their operation, and makes me wary of considering further purchases of Wyze products.

Been a while, but to update this issue, turned out that in my efforts to limit Google’s intrusions into how I used my Android phone, I had disabled Google’s Webview app in order to make my own choice as to what app would present Web content when I clicked on a link in emails or tests. Apparently, Wyzecam uses Webview. Re enabling Webview resolved the problem. 2020-03-08T05:00:00Z

1 Like