Wyze app 2.42 Release - 5/25/2023

Hang in there. It’s the year of the camera. And they seem to be building momentum all around. :slight_smile:


Amen brother, that’s my gripe with Wyze as well. Looks like whoever designed the interface didn’t care much. Shame on you Wyze,

BTW, Wyze app also works on a Mac as long as you have an M1 or M2 silicone Macs. Here is a proof from my M2 2023 Mac mini.

Curious if you removed your existing app first and did the install fresh? I did that as my Wyze Sound for VoIP has not been working and this seemed to correct it.

I just found that the Doorbell has vehicle selected as well. :slight_smile:

1 Like

My iPad has 2.42.0 (23), but in landscape mode it starts to load in full screen but then drops down a bit, still showing the full camera view but the top 3rd of the screen is blank. Is it supposed to do that? I get it that the iPad display isn’t the same screen size to get the full camera view but instead of the top 3rd being blank, wouldn’t be better if maybe it had smaller blank areas on top and below the video feed. It would look more aesthetic.

Not sure if camera group connectivity is a function of the app and/or the firmware but this remains to be the case for me:


…and after recent mesh router firmware update:

New App does not fix. Issues I have with cam v3 and older versions of Android on my devices.

It seems to work with timeline on Pixel 7 but not Samsung Galaxy a12 (android 12 (one UI core 4.1)) or Chuwi hi 9 pro (Android 8)

timeline does not line up
If an event is selected to play back from SD card. The play bar is not on the actual shaded clip zone. The clip will play as long as you don’t try to actually move on the clip which will then say " no events".

Customer service is not been much help but did mention that they’ve heard of it and if they can do anything we’ll update in the app. Here. We have a new app version and no change.

I’m curious if anybody else has this issue and if not, what settings could be causing this because I’ve tried everything that customer service has suggested and even with this iPad removed it completely from both devices and reinstalled it without change of the error.
Since it’s working with pixel 7 (android 13) I can only assume that says something to do with the Android version. This company should allow for rollback to the last working version for that particular device.

I am running the most recent production app on Android 11 and have not experienced any issues with the Event Viewer Playback SD Card icon button launching back to the SD Playback UI out of time sync. It places me exactly at the moment of the event video.

However, there are variables to consider that may be affecting your particular issue. I record to the SD Card Continuously, all my cams are assigned to Cam Plus, and all of my cams are accurately time synced with my phone and app.

For Android, go to APK Mirror and search Wyze. There you can find prior release app version APKs to download and install. You will need to uninstall the current version first.

Well it would be disappointing if I had to continuously record as the idea of event clips is to save time looking through security footage.
It would be disappointing if I had to subscribe to plus to get features that used to work.

Since I have a Pixel 7 and it works, I still think it has something to do with the android version and coding. The issue is Pixel does not have SD card slot and I need to archive events for a court case. So I went back to my older device which does . The only other difference is both phlablet and A12 do not have an SD card installed. My carrier will not allow me to just swap my card in the device to check if that has anything to do with it. I doubt it but what I have mentioned are the differences.

I use all my cams for security and don’t find it an issue. I use the Events uploaded as my time index markers so that it jumps directly to the SD Playback at the appropriate time. Granted, that is currently an issue for you since it is placing the time index in the wrong location on the Playback timeline, however that is something that should be able to be solved once troubleshooting narrows the cause. I was listing those variables as an indication of things that might be contributing factors to the issue you are experiencing, not requirements for it to work properly. Testing your scenario with those variables changed or checked might pinpoint where the problem originates. Switch to continuous temporarily, log some Events, and see if the issue rectifies or if it continues. That will rule out that variable as a possibility.

Not suggesting that you have to. Again, a variable that may be contributing. There have been multiple issues that cause variations in how cams and Event videos are reacting when assigned to Cam Plus Lite. Variables have to be tested and ruled out to narrow the cause.

Pixels have OTG (On The Go) capability thru the USB C Charging Port. That port is both Data and Power enabled. This means you can plug in a USB C data storage device and it will mount and read it as an external drive if it is properly formatted. I use the External Card Reader below all the time to read the SD Cards from my Wyze Cams and it works on Thumb Drives and other media types.


Aw this sucks. Now the issue is happening on my pixel 7. I uninstalled the app and reinstalled it and now all devices have this error. I can hardly use the playback feature.
I click on events and then click on playback and it will play the event but the playback bar is on the timeline before the actual event. If you move to the event it doesn’t know it’s there. Something’s off with the timeline formatting.

Thanks for the info, but I’m sure you’re well aware that having to attach a device to the phone should not be. But that’s my issue with the pixel and not doing my research that it didn’t have an SD card slot when the Samsung phones do.

It’s not permanent but they’re not rapidly fixing it as this has been going on for months and I’ve submitted all the logs and they tell me that goes directly to the engineers and there’s nothing they could see on the logs because the engineers have them. But they’re not saying if the law is showing the issue.

I’ll definitely try to set it to continuous but I don’t have a large enough SD card. Again. The camera should not have to run 24/7 because this was not an issue before. I use the app on that particular phone for almost a year before issues.

As for the issue on the pixel 7 now, I’m not exactly sure how, but when I saw your email come in I looked at it and then went back to the app and it reset the timeline where I had been trying to and the playback bar was in the right spot and skipping forward and back was working again. So it may be an issue from going from the event section to the SD card and I will investigate.
I shouldn’t have to do this r&d for them.

When you watch the Live Stream from that cam, is the time stamp in the lower right hand corner the same time as each of the phones?

If you start them all the same time at first it is the same time but the Galaxy a12 starts losing seconds. The one with Android 8 only loses a couple seconds and seems to hold, but the galaxy keeps losing seconds in comparison to the pixel. However, the pixel seems to quickly pass over some numbers or it’s faster than seconds and I’m assuming that’s because of the Wi-Fi speed maybe? Or does the time stamp work off of the SIM card which isn’t present in either of the older Android?

So in summary, the slightly newer Galaxy a12 is getting up to 20 seconds slower in the test. I didn’t let it go for too long to see how bad it gets. If you back out and start over again it resets. But then starts losing pace with the pixel.

My question was moreso to verify that your phone was displaying the same time as the cam and that the Time Sync wasn’t off by the margin being displaced within the SD Card timeline jump. The cams all have a user Time Sync feature that will align them should a time variance occur.

What you have described sounds like an issue with video stream lag caused by WiFi speed degradation or phone processor capability in streaming and playing the video. One setting in Android that may help with this if your phone has a capable processor is in the App Settings → Enable Hardware Decoder.

1 Like

Hi @WyzeJasonJ What do you mean by has new sound detection options? Does this mean I can set my own mp3 sounds based on individual notifications like "people detected and "animal detected? If so, what is the process?

Do I wait for the app to detect a person and then hold on to the notification and change the sound to my preferred mp3?

Per the Release notes, the new sound detection features are only for Cam Protect customers:

  • Added support for Glass Breaking and Gun Shooting sound detection for Cam Protect customers.

This can already be done on Android for your Wyze Global notification by recording your own MP3 and choosing that as your WyzeMessage channel notification tone. To do this for individual devices (cams, sensors, etc.) and for notification types (person, pet, etc.) you would need to record an MP3 for each and designate those within MacroDroid, BuzzKill, or Tasker as Wyze does not yet provide individual device or notification type tone functionality.

1 Like

Thanks for your input I think maybe, and this might be premature, that your suggestions are leading to the solution to my issue.

Checking the live time with the phone clock time I noticed it was off by a minute. It’s too hard to tell, based on the poor timeline markings exactly how far off and is it the same so I investigated further.

Yes I’m well aware of time sync feature and periodically was doing that even when there wasn’t a problem. But it didn’t seem to correct the problem just so you know.

So I continued on into the time settings and compared it to the phone where the app works and noticed that my phone wasn’t at the same time. Maybe a minute difference. So I went into the Galaxy phone settings and I’m assuming because there was no SIM card it wasn’t set to read off of the network time.
So I just took a shot and turned it on to set automatically thinking maybe it would grab it from the router or the emergency cell tower settings. As I said I do not have a SIM card in the two devices that showed app issues.

I will say I don’t understand why this worked but it seems now that the time bar is going and that the time is holding steadier. However after I use the time SYNC feature in the app now there’s one second difference. I’m testing to see if that increases. Could just be a small lag in the menu bar time change. Might not be a full second even

I don’t understand why the time would have anything to do with the timeline on the SD card. If I’m watching an event from yesterday the time is different on the phone today so why does it need the current time to sink on the timeline properly? It should just be relative to the time it was recorded.
It also raises questions of if they use Network time in the settings is set what is it facing it off of on the device that doesn’t have the SIM card in the phone?

When will the garage controller be fixed? Which release is that slated for? Currently you can’t have the rule check if the door is open and only if it’s open, then close it. Instead of the door is closed, it opens the door and recloses it.

It has been my experience that the app uses the phone’s time, updated by the network, in most of its functions, including the launch back to the timeline. Rather than launching to a specific time, it launches to (current time from phone - x min, y sec). It is a calculation rather than a direct time transfer. Therefore, the link that takes you to the SD Event from the Events Tab is affected if the time on the phone isn’t correct. That’s why I asked about the time sync. Users who have placed manual corrections on their phone so they are always early (5 or 10 minutes ahead) and never late experience these same issues.