Wyze App: 0 Kb (Solved)

I ran into an immediate problem with Wyze Cam v3s and what I believe is a drifting IP issue in the network stack. Who knows.

Yesterday - I bought four Wyze Cam v3s and hooked them up to my WiFi. My network is nothing special: I am using a Netgear RAX70 with just the 2.4 Ghz SID to connect the cameras as well as an AC2200 Mesh Extender, same deal with the SID. No 5 Ghz. No 20/40 coexistence thing. No weirdness with IPv6. Everything else in the house works. Out of the box though, these cameras didn’t.

After connecting the cameras I went to my app on my Android to view the live video stream, I immediately noticed the video was choppy and strayed in the SD/360P range which is atypical for the experience in my household. What was worse was that it was ranging well below acceptable bandwidth speeds - the low Kb/sec speed in teens or single digits making my video look like an mid 80’s Max Hedroom infomercial. And what was just a showstopper was that after 5 seconds of video, the speed slowed and stopped at 0 Kb/sec. It picked up again after a brief pause but the cycle repeated several times, landing me at 0 Kb/sec and frozen video. I thought this was a Android thing, tried it on my iPad and while a little better, still froze about 7 seconds in at 0 Kb/sec. Nothing wireshark can’t figure out!

I am going to assume these cameras use RTSP, RTMP or similar for transmitting video between the camera and however the app-goo works with some sort of rtsp:// that may (or may not) include the local IP from my router. I had to go into my router and statically assign IP addresses (“reserve IP address” in common routers) to correct this problem for what ** appears ** to be drifting IP space within the network stack, either on the camera or between the camera and the phone app/software. But when I pinned up the IP addresses & rebooted the router - the problem went away. No more 0 Kb/sec anymore.

Wyze, you should really look into this. I have seen this problem in and around forums, Reddit and decided to post here to help. Seriously though - if you expect customers to bust out Wireshark, a net analyzer and start inspecting packets, you are going to have a short lived success with whatever “problem” this is… it wasn’t easy to solve.

[Mod Edit]

Moderator Note: Personal information has been manually removed from this post. Such information often gets included inadvertently in an email signature block when replying by email. The forum software attempts to automatically remove email signatures but it is not always successful. When replying to the forum by email, it is best to remove the signature block yourself before sending.

Interesting topic because I’m having nearly the same issues, but only with Wyze Cam Outdoor and only via cellular Internet.
I can clearly reproduce this with a device of my friend, same issue. You can click on the device, you see the picture and sometimes 1 second video Clip and then the picture is frozen, the connectivity rate goes down to 0kb. You can refresh the Image if you go back and click on the camera again, but also the video is frozen again. This only happens If you connect outside the local network, via lan all is fine. I and my friend have both newest firmware and it was working, this must come a few weeks ago or with a firmware Update.

Perhaps someone also having such behavior with outdoor cam?
Ah and another thing … I never got the timelapse working on android with the outdoor! Apple devices working Like a Charme and also other cameras with android. But wco with android Not :frowning:

No, the V3 cameras don’t use RTSP - unfortunately. Eventually Wyze has stated that they will release RTSP firmware for the V3 cameras. I don’t know what protocol they are using.
Regardless of you assigning a DHCP reservation in your DHCP server (router for most people) or not should not make any difference since as far as the cameras are concerned, it’s still just a DHCP assignment. The camera has no way of knowing that the router assigned a specific address because of a reservation. Additionally, if your DHCP server is like most, it will keep assigning the same address for a particular device even without a DHCP reservation as long as the client device keeps renewing the DHCP lease.
Since you mentioned WireShark, have you looked at packets with WireShark to see what it was doing? I don’t think I ever have - but could…