Windows 11 and Wyze app -

Time for a PC upgrade -
Is ANYONE here running the Wyze App w/ Windows 11?
One thread over in roadmap
Talks about it but does not point to any success.
Mention sideloading, which I do with my Kindle.
So I would appreciate any quantitative insight.
More details the better - how much bandwidth does it use?
Memory requirements?

1 Like

It’s not ready yet in Native Windows 11 (without side load/BlueStacks)… So far on Windows 11 I have been able to install the Amazon Appstore which uses the Android backend but it is limited to 50 apps at this time. If interested in getting this far good article here.

How to run Android Apps on Windows 11 with Amazon AppStore? (

But can it successfully be sideloaded to Win11 without Bluestacks?

I have not tried that. I did read where an UX/UI student was successful but 3rd party apps were involved and I didn’t want to take my gaming PC down that path.

Edit: Here is the article


There is also a link there to an app for sideloading without Play Store, but even more simply it seems good old fashioned ADB command line can do it. :slight_smile:


Just wanted to Chime in here that I have successfully loaded the latest Wyze App into Windows 11:

It looks pretty good actually. It basically looks like it’s running natively in Windows, as compared to Bluestacks where it’s obviously an emulation. I’m impressed. I can use it on my touch screen or I can use it completely with my mouse.

I had to sideload Windows Subsystem for Android (downloaded the file directly then installed it with powershell). Then I download the Wyze APK and used ADB to install the Wyze App.

I can at least confirm that it does work and it’s nice to have use of my Wyze app on Windows. I am running the latest app though, and I will say there have been a few times where the app has crashed while I’m cruising around, but it’s mostly from the emulation being in early stages I am sure, and it’s not constantly crashing or anything. It is nice to be able to change it to different sizes and the emulation just automatically adjusts:

I also love having it pinned into my task bar so I can immediately load it easily. I can set shortcuts for it anywhere just like any other Windows app, it’s basically treated just like any other Windows app.


These are the requirements to install Android apps on Windows 11:

  • Memory: 8GB (16GB recommended).
  • Processor: Intel Core i3 8th Gen, AMD Ryzen 3000, Qualcomm Snapdragon 8c, or better.
  • Storage: Solid-state drive (SSD).
  • Microsoft Store app: Version 22110.1402.6.0 or higher.
  • Windows 11: Build or higher.
  • Windows Insider Program: Beta Channel.

I THOUGHT I read somewhere that touch screen was required, but I don’t see that in the requirements I just copied, and I have to say that I have been able to use the Wyze App just fine using just my mouse, so I am thinking you’d be able to use a lot of things without a touchscreen…such as the Wyze app. On the other hand, you might NEED a touch screen for a multi-touch app like Call Of Duty Mobile :wink: since your mouse cursor can only be in one location at a time. I haven’t tried any multi-touch apps yet though…though here we’re mostly talking about the Wyze app, and it works. I can confirm that.


Awesome @carverofchoice.

Was really hopeful that the virtual load would do it… but I believe it will stay tethered to the Amazon store. Which is just a shame.

I may give this a whirl at some point.

1 Like

FYI, Google just announced they are launching Google Play for Windows in 2022. They haven’t specifically stated that anything besides games will be available since the announcement was made at the games awards, so they focussed on that, but they did confirm they built their own integration for Windows and that it will also run on Windows 10.

In addition to games, hopefully they will also allow other apps from Google Play (again, they only talked about games so far because the place they announced it is all about games…but presumably if you can run a game on it, it wouldn’t take much, if anything to extend that capability to any other app too).

Google stated they are doing this totally separate from any Microsoft partnership, which probably has Microsoft really upset they aren’t getting a cut from it like they will with Amazon, and that Google is allowing it to run on Windows 10, which will make people feel a lot better about not upgrading to Windows 11 now like Microsoft wants…being able to use Android on Windows was one of the biggest motivations for people to upgrade to Windows 11 and now Google is interfering with that incentive.

But hey good news that it might soon be possible to use the Wyze app on Windows 10 too! :slight_smile:


I finally got the Wyze App working on a Windows 11 Laptop using the instructions listed at the end of this post.

First problem I encountered, was a V3 Cam, when clicking on the settings gear, it takes the app right back to Wyze home screen with a quick flash of the green Wyze splash screen.

A V2 Pan Cam, when clicking on the settings gear, it threw me back to the V2 Pan Cam’s main screen for that camera.

A WCO let me into the settings via the gear, and I was able to click on ‘Name’ to rename the camera, I then clicked on ‘detection’ settings and it threw me back out to the main settings for that WCO.

I click on a Wyze Color Bulb, it crashes the app.
I click on a Wyze light strip, it crashes the app.

The main reason for wanting to use the Wyze App on Win 11 was to manage Rules with a real keyboard and mouse, so, into rules I go… was going well at first, but I get random crashes here as well. I was able to delete two rules without issue a few times, other times the Delete was followed by getting thrown back to the Wyze Main Menu. I was successful at copy/paste from the app to a spreadsheet in windows for the “Name” field…

Clearly not ready for prime time, and I think it’s safe to say you’ll get no support from anyone on trying to get the Wyze App to work properly in this unsupported setup…

Oh well… it was a fun dream until I woke up and realized this was a wasted venture… back to
Managing rules on my phone… Sigh



Later this evening, creating rules, copy/pasting Text from the Rule Titles to a spreadsheet from the Wyze App on Windows 11, made for a somewhat pleasant experience. Not near the number of Crashes of the app, or other strange misbehavings as I had earlier on my first run with the app.


1 Like

I have tried the same using the apk file from Apkmirror. I can launch it OK but it disappeared after I have enterred the account and password. Do you have the exact name of the Wyze apk?


The version I had working before has started doing this same thing too (disappearing after it loads). I have read that a good solution to this happening with some apps may be to install Google Play on Windows and then install everything through that. It is a lot more complicated to set this up than normal side-loading as you need to do some extra modifications, but apparently, it works a lot better.

Personally I suggest waiting a little bit because the Microsoft guy in charge of the project announced about a week ago that they were finally launching a public preview of the Android use stuff.

Also, last month Google promised they were going make Android work better with Windows and other operating systems. So I expect things are about to get a lot more stable within the month or so.

If you can’t wait though, I would google how to install Google Play and see if that helps make it work better as some say…but like I said, mine was working great but then suddenly started disappearing when it loads. I chalked it up to some Windows update breaking the functionality since I basically brute forced the feature into compliance before, so they weren’t really trying to keep things compatible for me.


Oh … Thank you very much for a quick and detail reply. I will follow your suggestions …

1 Like

I have installed Google Play Store using this link The Easy Way to Get The Google Play Store Working on Windows 11 [Updated] - (won’t take long).

However Wyze app is no where to be seen. I am not sure where the problem resides … Windows 11, Google Play store or Wyze app itself does not wanted to be included in this setup

That is really weird. it doesn’t even show up in the list of apps when you search for Wyze? I wonder why. You’d think you should have access to everything. Others have inferred that doing this would allow any app to be installed. Thanks for sharing, now I am really wondering why it doesn’t show up for you :thinking:

1 Like

I also have the same problem with the Wyze app not showing up in Google Play. I sideloaded the app in Windows 11, but it also disappears. Hopeful for a solution in time.

Anyone have any success at getting Wyze App to install and be usable on Windows 11 yet? Or is it still a hit and miss circus?

Last time I installed it, I could get to open, and view a few feeds here and there. But do something ‘advanced’ like navigate through the settings of a Camera, and that was too much for the app, as it would crash back to the main screen of the emulated android app.

Maybe it has something to do with the haphazardly programmed Wyze App v2.xx that is being held together with duck tape and bailing wire.


I had a guy tell me in DMs that he got it working on his computer recently.

Working, as in ‘fully’, to where one can actually go into settings for all the Wyze cams, etc, without in crashing?