Wifi password too long


I’m trying to setup a new camera (V3) with RTSP, and have managed to successfully flash the RTSP firmware. However, during the setup, when it asks my wifi password, the textbox is limited to 64 characters maximum, and my wifi password is longer than that, so I can’t get it to connect to my wifi.
Changing my wifi password is not an option, as I have way too many devices to go through and reconfigure if I do that.

Any recommendation for how to workaround it?


Setup a 2nd ssid with a shorter password.

And I thought a couple of mine were long - at 53 characters.
I have run into other devices that won’t take really long passwords. Only solution is to shorten you long password or as WildBill said, create another SSID with a shorter PW.

Agreed. Unfortunately, someone that sets a wifi network with a 64-character password and then sets another network SSID with a shorter password would remove the reason why the first SSID was set with 64-characters. :grin:
The chain is only as strong as its weakest link.

If your WiFi and networking is decent, you can HIGHLY restrict the capabilities of devices connected via that second SSID. My IoT network can ONLY access the internet, and is isolated from all the rest of my network.

I am thinking renaming the first SSID as { “City name” Vice PD} should be a good deterrent.

I wondering what the situation is where a 64-character WiFi password would actually be required. Does the OP live next to where Black Hat and Defcon are held? :smiley:

It isn’t quite the same as the password to an account on an internet site that the entire world potentially can access. Only those within range could launch an attack to attempt to gain access. A password half that length would make almost any hacker give up in frustration unless state-level secrets were on the network behind that WiFi (in which case they shouldn’t be on the same network).

I would feel sorry for anyone setting up a device like an Echo Show on such a WiFi connection, or any other device where there is no option other than typing in the password on the device’s screen.

I seem to remember when I setup my first Echo they couldn’t use special characters which was also a problem since I had them in my wifi passwords.

Thank you everyone for your responses. Didn’t expect to get this much activity on a Sunday post :slight_smile:
I do have a separate SSID which I can connect to, of course, but I’ve mentioned RTSP intentionally, as I’m trying to get access to that IP address from the security management software, which is on the same “overly secured” network. So changing password or SSID is not an option.

One thing I’ve discovered after posting the question, is that few of my earlier WizeCams (v2, again using RTSP firmware) are actually on that network. That means, this was possible in the past (not sure how far back that was, as I’ve installed these at least a year ago (if not earlier). So seems like there was a breaking change at some point in the Wyze App, to limit the length of the password allowed.

Well sounds like your not going to get it to work. No reason to have a 65 letters,numbers